Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Debian 6 guest (VirtualBox) sitting on a Windows XP host. In Debian I've configured tightvncserver. In Windows XP I've installed TightVNC client.

On Debian I do the following:

$ sudo netstat -nr

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
10.0.2.0        0.0.0.0         255.255.255.0   U         0 0          0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
0.0.0.0         10.0.2.2        0.0.0.0         UG        0 0          0 eth0

$ tightvncserver

New 'X' desktop is rand-office:1

Starting applications specified in /home/randm/.vnc/xstartup
Log file is /home/randm/.vnc/rand-office:1.log

On the Windows host, in the TightVNC Viewer, I try to connect to 10.0.2.2:5900.

After ~20 seconds, it tells me that it failed to connect to server 10.0.2.2.

Question: what am I doing wrong?

===EDIT===

I'm able to connect via PuTTY from the Windows Host. So some amount of connectivity is working.

share|improve this question
    
Most probably, theLinux Vm is connect to Windows Host using NAT. Try changing it to bridged. –  Ganesh R. May 26 '11 at 15:32
    
It was on NAT. I changed to bridged. The IP address changed ... trying the new IP address (@ port 5900) failed to connect in 1 second instead of 20. –  Begbie00 May 26 '11 at 15:37
    
Which are the firewall settings for the guest machine?. If you do a "netstat -lp" on Debian, do you see vnc listening on tcp/5900? –  DrNoone May 26 '11 at 16:38
    
Bingo ... Xtightvnc @ *:5901 instead of *:5900. Now I just have to figure out how to secure all this stuff. Thanks much. Should I just delete this question or close it so that the trail is here? –  Begbie00 May 26 '11 at 16:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.