Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have a set of three devolo dLan 200 AVPlus (I'll abbreviate to dd2p) set up as follows in our house:

modem -> dd2p_1 --> dd2p_2 -> Router 1 --> PC1
                |                      |-> PC2
                |                      \-> PC3
                |
                \-> dd2p_3 -> Router 2 --> Server PC
                                       |-> PS3
                                       \-> XBOX 360

Router 1 is in the loft and is functioning correctly. However, router 2 is in our living room, and does not get an IP address assigned from dd2p_3, no matter how often I try to reset it. It does this both when dd2p_3 shows up in the dLAN Cockpit, and when it doesn't.

Has anyone ever had something similar? I'm at a loss at how to solve this.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

First of all dd2p_3 seems to be the devolo powerline device. These devices do not assign IP addresses (they don't run a DHCP server). So your Router 2 will try to receive a DHCP address via dd2p_3 -> dd2p_1 connection from your modem. However depending on the modem it might be limited to one local IP address. You did not include details about your internet connection. But "modems" typically do just bridge the connection to your ISP. So finally your LAN devices get IP addresses from your ISP directly.

I live in Switzerland and here this setup is common for cable operators (Cablecom) where the ISP provides a modem which just bridges the LAN and a machine attached to the modem gets an IP address directly from the ISP DHCP server. Unfortunately it's also common that such ISP do provide only one single IP address to their clients. So the first router connected would get the public IP assigned while the second one does not get one.

The solution would be to change your setup slightly using only one router:

modem -> Router 1 -dd2p_1 --> dd2p_2 -> Switch 1 --> PC1
                     |                      |-> PC2
                     |                      \-> PC3
                     |
                     \-> dd2p_3 -> Switch 2 --> Server PC
                                            |-> PS3
                                            \-> XBOX 360

In this case your Router 1 gets the public IP from the ISP and internally distributes local IP (usually 192.168.1.0/24) to your clients. Router 1 would in this case perform NAT translation hiding all your internal stations behind one single IP.

If you would like to separate LAN segments you might also use a more complex setup:

modem -> Router 1 -dd2p_1 --> dd2p_2 -> Router 2 --> PC1
                     |                      |-> PC2
                     |                      \-> PC3
                     |
                     \-> dd2p_3 -> Router 3 --> Server PC
                                            |-> PS3
                                            \-> XBOX 360

This setup is more complex as you have to use independent networks and if PC1/2/3 have to access the server it requires special routing configuration too. That's why I would recommend the setup above for simplicity (all hosts managed by single router).

Of course it would also be possible that simply the connection between dd2p_1 and dd2p_3 is not working. This is quite common if you connect powerline devices to different power rails in an apartment. However reading your description I would bet that your "modem" just hands out one single IP which is picked up by the first router so the second one does not get an address then even if the connection on powerline is fine.

share|improve this answer
    
Oooh, I hadn't thought of it that way! I'll have to juggle around a bit with the configuration to see what works. The routers are both also wireless routers so just having one downstairs wouldn't work, but maybe I could put router 2 between the modem and dd2p_1, and a switch in the living room. I'll get back to you after I've tried it out :) –  Aistina May 26 '11 at 20:08
    
Well, if possible you should use one router only (directly connected between the modem and the rest of the LAN (see my diagrams). If you need a second one just for WLAN coverage I recommend to connect it via one of the switch-ports (not the WAN port) and disable the DHCP server via control interface to avoid address conflicts. Or just get a pure WLAN access point without routing functionality. –  SkyBeam May 26 '11 at 20:14
    
YES, it works! I've set up the WLAN router in the loft to use 192.168.2.x instead of 192.168.1.x (the default). I may change it in the future so that everything uses the router downstairs as its DHCP, but at least everything works now :) Thank you so much! –  Aistina May 26 '11 at 20:38
    
You're welcome. I am glad to provide the solution :) –  SkyBeam May 26 '11 at 21:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.