Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A friend sent a long a file (a .rar) he wanted me to check out for him before he installed it.

I downloaded it and unrared it with no problems, but it was full of .exe's instead of the intended contents (fonts) so I advised him to delete it immediately and not use.

I then proceeded to do the same, but the folder simply will not delete. Oddly the files went fine, and I never ran anything, but this is what I'm seeing:

Could not find this item

This is no longer located in C:\Users\This_User\Desktop. verify the item's
location and try again.

I've tried the following things with no help:

  • Using "Unlocker" to Unlock and delete
  • Using move on reboot and rebooting
  • Using PendMoves (from sysinternals) and rebooting Elevating a cmd line, doing a dir /x to get the short name of the folder, and then del 'shortna~1'
  • Moving the folder to a new folder and then trying to delete the parent folder

I'm on Windows 7 RTM, very fresh install. Any thoughts?

Update: Just to confirm, I've run Hijack this and half a dozen other malware detectors, and everything came back clean (no extra processes, no other obvious badness). Rebooting in safe mode didn't help either.

share|improve this question
4  
Some part of the NTFS filesystem is damaged. I've had this issue. Never was able to fix it without a reformat. – Fake Name Jun 30 '10 at 5:39
    
if you have this issue, try Cale's suggestion - worked for me. – Mark Heath May 31 '11 at 19:27
    
The problem here is that del doesn't work for folders. Correct syntax would be rd shortna~1 /s to remove the folder/subfolders/contents. – EKW Mar 19 '12 at 18:27
    
I had this exact problem (once in my life). I had to reboot in my linux and delete it from there. No matter what I did from Windows 10 it didn't worked. From Linux I could do a normal delete. – Heroselohim Feb 14 at 0:58
    
This was the folder name: "the 100 subtitles" (located on desktop) and was already empty. When looking into the security tab about the folder It was not accesible. Hope this info helps. – Heroselohim Feb 14 at 1:05

16 Answers 16

I know you said that you tried deleting the shortname of the file and it didn't work for you, but it does work for some forms of this problem. It worked for me. So for the sake of completeness I am mentioning it here.

Step by step:

  1. press windows key + r
  2. type cmd.exe, press enter
  3. cd \to\the\folder\containing\the\problem\file
  4. dir /x
  5. Note the short filename of the problem file. It will look for example like BLAH~1.
  6. del BLAH~1
share|improve this answer

Try the DelinvFile tool. It worked for me perfectly when NOTHING worked before.

BR, galmeida

share|improve this answer
    
this worked for me – Pup Apr 1 '11 at 18:23
    
Works great, shame it's not freeware - but anyway 3 actions are more than enough for me) – Zotov Mar 30 '12 at 22:18
    
also worked after nothing else did. thanks a lot! – Boris Samardžija Sep 1 '14 at 16:36
    
This is also worked for me when nothing else did – adampski Dec 16 '15 at 8:25
    
DelinvFile is working perfectly. Tested it with Windows 10 – Hartmut Jan 6 at 1:49

Boot into a Linux live CD environment and delete it with NTFS-3G?

share|improve this answer
    
+1 I was about to suggest that. – Bobby Feb 17 '10 at 12:40
    
+1 good idea...... – studiohack Aug 14 '10 at 0:53

Ah ha!!! I did it!!! This was so annoying but after several hours... it dawned on me. Basically, you make a folder with the same name as the missing folder, then you drag the folder into the folder with the missing folder. Windows did not ask me to combine the folders, but after that, Windows knows where the folder is and you can delete it. I didn't try to copy and pasted I'm guessing that would work too.

share|improve this answer
    
This solution works on Windows 7. Please post if it works on previous versions. – Cale Mar 28 '11 at 5:44
    
Genius! this works! I had the same problem after extracting a zip file (from Program Files\Visual Studio) into my user\downloads folder. It resulted in a weird folder containing files I couldn't access or delete. I followed this advice, Win 7 asked me to merge which I said yes to, and then it let me delete the folder with no fuss. – Mark Heath May 31 '11 at 19:25
    
didn't work for me - I then somehow had 2 identically named folders in alongside eachother! – Shevek Jan 28 '12 at 10:49

Isn't there a special character in the name of the directory? Like an "empty" character that looks like a space but is not a space?

Have you tried a "Check Disk", as the directory entry for that directory or its parent might be corrupted?

share|improve this answer
    
no special characters. check disk reports nothing. – aronchick Sep 21 '09 at 3:37
    
I have the same problem. In my case it is a space character that follows the folder name. – MSX Nov 12 '14 at 17:22

This worked for me :

1. press windows key + r
2. type cmd.exe, press enter
3. rd /s "\\?\D:\bad\folder\path "

Notice the space at the end of "\\?\D:\bad\folder\path "

share|improve this answer

Are you sure the folder is actually empty? There could be a file marked Hidden and Read-Only, or System in there. Windows could be blocking you from deleting because of the Hidden+RO or System file.

Haven't got a Windows 7 machine handy here, but in Vista you'd make sure that you can see all the files by opening Explorer, clicking "Organize", selecting "Folder and Search Options", then clicking the "View" tab. If you scroll down that screen you would see a "Hidden files and folders" option, make sure they're shown, then scroll down a little more to where it says "Hide protected operating system files" and make sure that isn't selected.

Now have a look at the folder and see if there's anything more in it.

Alternatively open a command window in the folder and type attrib see if any files show up (probably with SH or HR flags set on them).

share|improve this answer
    
Nope, nothing there. – aronchick Oct 22 '09 at 18:00

This is a problem with the desktop not being able to auto refresh. Like others have said, try pressing F5 to refresh because the file may already be deleted. Here's a thread on the same problem: http://social.answers.microsoft.com/Forums/en-US/w7desktop/thread/249f4794-13c8-4fc5-939c-b3d1fe6433fb The problem usually has to do with some program like WinRAR that copies files onto the desktop instead of Windows Exlporer.

share|improve this answer
    
Sorry, restarted, refreshed, etc many many times. No go. – aronchick Mar 5 '10 at 7:24

Before you do anything else, run some anti-virus and malware tools to make sure your machine is not infected with anything. You did open an unknown or possible untrusted rar.

http://superuser.com/questions/23633/clean-up-infected-computer-from-viruses

http://superuser.com/questions/20895/best-adware-removing-software-thats-free

share|improve this answer
    
Will do.... but can [mal|ad]ware spread just by extracting an archive? Not by running anything, just extracting? – aronchick Aug 24 '09 at 17:47
1  
Was it a self-extracting rar? If so, those could potentialy be dangerous. – Troggy Aug 24 '09 at 17:49
    
Nope, just used "ExtractNow" to expand it, and that was it. No joy on the anti-malware tool... nothing found, and it's still undeletable. – aronchick Aug 24 '09 at 17:58
    
What happened when a current virus scanner looked at the files in that rar? – Troggy Aug 24 '09 at 18:08
    
Unfortunately, deleted the archive when it was clear it was filled with badness. – aronchick Aug 24 '09 at 18:10

Safe Mode is also something to try. That or if it's already too late, see if you can identify the process name, and use Hijack This to get rid of it.

share|improve this answer
    
it doesn't appear to be a process of any kind. and nothing is coming up on malware. – aronchick Aug 24 '09 at 19:01
    
Safe mode didn't help - Hijack this didn't report anything. – aronchick Aug 26 '09 at 20:21

Try hitting F5 after you delete. It may be that it actually has been deleted but the view hasn't automatically refreshed. I had the same problem. Also newly created folders or renamed files wouldn't show up without refreshing. Unselecting the two navigation pane checkboxes under the general tab in folder options seem to fix it.

share|improve this answer
    
Nope, not a refresh issue... – aronchick Mar 5 '10 at 7:25

Could it be that the full path of this directory is too long (>255 characters)? If so, try renaming the directory to something shorter and then deleting it.

share|improve this answer
    
Nope, renamed it to something short, still no go. – aronchick Mar 5 '10 at 7:25

I had a similar issue, attempting to remove files I had copied across a networked bridge from an installed virtual machine. It seemed nothing I did would remove these: I tried the "Take Ownership Registry Hack", and the even more powerful "AccessGain MiniFilter Driver" (http://www.hobeanu.com/blog/) Which in Windows 7 64-bit requires quite a concerted effort (http://msdn.microsoft.com/en-us/library/aa906338.aspx). Inside the Windows 7 64-bit GUI, it seemed nothing would remove these files - I was stymied across every approach.

Finally, I reached into my quiver for an old trusted friend.

The Command Prompt

I was still booted in the "disabled driver signature enforcement session," that I mentioned above. The "AccessGain MiniFilter Driver" (http://www.hobeanu.com/blog/accessgain-tool/) was installed and was giving me a superuser 'God-like' control over anything on my drive. At this point:

  1. I fired up an "Administrative Rights enabled Command Prompt," (http://www.howtogeek.com/howto/windows-vista/enable-the-hidden-administrator-account-on-windows-vista/)
  2. Navigated to my Desktop. I used the command: "cd c:\Users\superuser\Desktop"
  3. (Note: Change the term "superuser" to your account name.)
  4. Looked to see if the files were present. I used the command "dir backup"
  5. (Note: All my files had the word "backup" in them. If different for you, replace term)
  6. Then I simply deleted the files. I used the delete command: "del backup"

When all else fails, pull up your sleeves and get your hands dirty with the trusted old command prompt... Hope this helps some of you. I was pulling my hair out on this one, and when I resolved it, thought it might be worth sharing.

Cheers!

share|improve this answer
    
This is interesting, but it's not a command prompt issue. I should have tried to boot into disable drive signature enforcement session. – aronchick Mar 21 '10 at 21:50

I was having the same problem. using delinv i was able to delete the folder(s)

share|improve this answer

This problem (folders in Windows 7 containing executable files being inaccessible) is not a permission issue, nor an open-handle issue. It happens when the Application Experience service is disabled. Set the service to manual to resolve it:

Run dialog (or command prompt):

  > sc config AeLookupSvc start= demand
share|improve this answer

I'm not sure if Windows 7 has Command Prompt. But you can delete it from Command Prompt. Go to the said directory and then use the command del against the file name.

  1. Go to Command Prompt "Windows + R"
  2. cd C:\Users\This_User\Desktop
  3. del "filename.abc"

This should work.

share|improve this answer
    
It's not a file, it's a directory - and as mentioned command line doesn't help. – aronchick Sep 21 '09 at 3:41

You must log in to answer this question.

protected by Community May 10 '11 at 13:39

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .