Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new dell XPS laptop. My external Dell monitor attached to my laptop.Everything works fine if my laptop lid is open, but if I close the laptop lid, I lose the display on the monitor attached to laptop. How can I close the laptop and keep the display on the monitor showing?

I've already tried this solution http://www.troublefixers.com/stop-windows-7-laptop-from-sleeping-on-closing-lid/ but still problem is same.

share|improve this question
    
Good question... I'm still looking for an answer here! Nothing so far I'm afraid. –  Noldorin Oct 24 '11 at 23:00
    
The solution you linked has a really roundabout way of changing the setting. Try the solution I mentioned in my answer instead. –  rob Feb 28 '12 at 19:58

4 Answers 4

By default, most laptops will go to sleep when you close the lid.

  1. Click the Start (Windows) button
  2. type "Power Options" and press enter
  3. In the left hand pane, click "Choose what closing the lid does"
  4. Under "When I close the lid:" select "Do nothing" (you can do this for on battery, plugged in, or both)
  5. Click "Save Changes"

Now when you close the lid, your laptop should keep running and should recognize that only the external display is available.

share|improve this answer

Try selecting the external monitor as a primary display. If that doesn't work check if there is a button to switch display outputs on your laptop.

share|improve this answer

I tested with my HP Compac 6710b / Windows 7 Pro with external monitor and found out that there is a Presentation state (got it by WIN+P). When choose Projector only I can close laptop and monitor stays on. Have to set laptop not to go sleep when closing lid also.

share|improve this answer

Edit for windows 8: While in desktop mode right click the windows tile button, select power options, on left hand side select choose when to turn off the display, below all the options click change advanced power settings, scroll down to power buttons and lid, then select lid close action, and change both settings to never. boom youre all set :)

share|improve this answer
    
The question was for Windows 7 though, not Windows 8. –  lzam Sep 22 '14 at 2:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.