Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an IIS7 on a Windows 7 Ultimate.

IIS7 works fine on computer hosting IIS7. But I can't access IIS7 from another computer, I get the following message: "server is not responding".

How can I fix this?

share|improve this question
    
you mean if you type the IP of the computer hosting IIS into the browser of the second computer it works? What exatly are you expecting? –  tombull89 May 27 '11 at 10:46
    
I've improved my question. From computer hosting IIS works fine, but from another computer a can't see anyting. –  VansFannel May 27 '11 at 10:50
    
ok, thanks for the edit. Can the two computers see each other (Ping them?) Also, check the Windows 7 Firewall. –  tombull89 May 27 '11 at 10:51
add comment

3 Answers

Is the computer on the LAN? Firewall issues? Try temporarily disabling the firewall, see if that helps.

Can you ping it? Does it respond? There are many reasons why, please provide us more information but hopefully the above will help.

share|improve this answer
    
If I disable Firewall, I get the same message: "Couldn't connect to server". –  VansFannel May 27 '11 at 11:00
1  
I remember that there is an option in IIS7 to don't allow external connections. With this option enabled, only computer hosting IIS7 can access it. –  VansFannel May 27 '11 at 11:01
    
Can you ping the address? As in Start > Run > 'cmd' > ping [ip address]. –  Muffinbubble May 27 '11 at 11:03
    
Yes, I can ping the IP address. –  VansFannel May 27 '11 at 11:16
add comment

Run the following tests:

  • Check connectivity from both computers.
  • Firewall settings, temporary disable the firewall from all profiles (private, domain, public) if this works, try adding a Port Rule to your firewall allowing incoming connections to port 80.
  • Also, it'd be important to check the bindings configuration of your website, bindings specify the address the server should listen to for incoming connections, make sure you have 'All Unassigned'.
share|improve this answer
add comment

If you developed your site with WebMatrix, and therefore are running IIS 7 Express, follow these instructions:

By default, WebMatrix binds to localhost, so if you try to use your machine name (i.e. allow other machines on the LAN) to view your site, it won’t work. The reason for this is that IIS Express (the WebMatrix web server) is designed to be run without administration rights. It’s not meant for production environments - it’s meant for simple development environments.

In order to do testing on another computer, you need to therefore make a few minor changes. Firstly, you need to be running WebMatrix as an administrator. To make the change so that WebMatrix runs as an admin by default:

  1. Close all instances of WebMatrix
  2. Find the WebMatrix executable (typically in C:\Program Files (x86)\Microsoft WebMatrix\WebMatrix.exe or C:\Program Files\Microsoft WebMatrix\WebMatrix.exe)
  3. Right click the executable, click properties, click the ‘Compatibility’ tab, and select ‘run as administrator’.
  4. Click OK.
  5. Open %USERPROFILE%\My Documents\IISExpress\config\applicationhost.config in notepad
  6. ctrl+f ), copy and paste the binding entry so that you have two copies, and change one of the bindings to “”
  7. Save & close the applicationhost.config
  8. Add a Windows firewall exception for external access to that port
  9. Launch webmatrix, and test away :)

If it bothers you, you can optionally turn of “User Account Control” on your system to prevent the admin rights prompt from coming up every time you launch the app. Remember to turn it back on later.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.