Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using emacs-snapshot on Ubuntu 11.04.

In some of the emacs modes, like Auctex and ESS, the menus have no contents, i.e. in Auctex when I click on the Preview, Latex, or Command menus, a small empty rectangle appears. The standard menus (File, Edit, Options, Buffers, Tools) have regular contents.

This has occurred around the same time as updating from Ubuntu 10.04 to 11.04, but I am not sure if they are related.

The problem does not occur using emacs-23.

How can I get the menus back?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

This is a valid Ubuntu bug: Bug #415101. The workaround is to set variable GDK_NATIVE_WINDOWS=1 before running emacs.

share|improve this answer
    
thanks for pointing out the bug - my experience - reflected in the comments of that bug - indicate that this fix does not work. The menus do open with F10, however. It also indicates that the bug is with all flavors of emacs, not just emacs-snapshot, but I only get the bug with emacs-snapshot (perhaps because the bug has been fixed in emacs23). –  David Oct 26 '11 at 14:27

Although this is a currently unresolved bug (as pointed out by @sindikat), the menus can be accessed with F10.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.