Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a regular PC keyboard plugged in a desktop PC with Windows 7

When I switched on the computer today I discovered that pressing U writes '4', O writes '5', K writes '2', etc. exactly as if you maintained down the Fn key of a laptop keyboard. This problem only happens if the num lock is switch on.

Is there anything I can do to fix this?

share|improve this question

Yeah... that's just plain ol' numlock. You would see the same result with numlock on and your external keyboard not attached.

Turn numlock off.

share|improve this answer
    
The problem is that this is not an external keyboard, I don't have a laptop but a desktop PC. And the "keep numlock turned off" solution doesn't really satisfy me :) – Tomaka17 May 27 '11 at 19:51
2  
@Tomaka17 How can you say it doesn't satisfy you?? The problem is that it is using the letter keys as a number pad, when the Num Lock key is on (Which is a feature by the way, it's supposed to do that...). That is the only and proper way to turn it off. And if it is a desktop PC, how is it not an external keyboard? – Connor W May 27 '11 at 20:20

I tried another keyboard, and this one is working correctly

I guess it was a problem with the hardware of the keyboard itself

share|improve this answer
1  
Try that broken keyboard in another PC to see if it does the same thing as well, just to confirm it is the keyboard thats broken. – camster342 May 27 '11 at 20:16

Check the keyboard type in the property settings. It may be configured as a laptop keyboard.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .