Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm somewhat new to the inner-workings of Linux so forgive me if this is a stupid problem.

I used the instructions on Ubuntu's website to build my LiveUSB drive from scratch. It seems to work perfectly except when I restart the OS.

Both shutdown -R now from the command line, and the restart command from the GUI seem to shutdown the computer successfully but when the bios searches for the USB drive it cant find it.

It almost seems like the drive isn't ready to be accessed yet. When I shut the computer completely off and then turn it back on it finds the drive just fine. Is there some trick to getting it to restart successfully? Is there some way to cause the system to completely finish with the USB drive before it starts the reboot process? I've tried the drive on a number of different computers with the same result.

Thanks in advance for any help!

share|improve this question

migrated from stackoverflow.com May 27 '11 at 20:02

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Try going into your motherboard bios settings and turning off quick boot. Also look for any other options that may pertain to this.

share|improve this answer
    
I'll check it out. I suppose it is possible that every machine I've tried with it has quickboot enabled. Thanks. –  rabid.sloth May 27 '11 at 20:54
    
It may not be the answer, but its certainly something worth trying. –  Will Gunn May 27 '11 at 22:01
    
So, just a follow up. On the same computer, using an SD card with the exact same Ubuntu LiveUSB image, I can restart with no problems... So perhaps it's the USB drive it's self. Bummer I bought 300 of them. –  rabid.sloth Jun 1 '11 at 21:38
    
Well it seems that there is something weird going on. I've found that if I install linux onto the drive directly, as if it's a hard drive, it will restart no problem. However, the liveUSB version is unrecognized by the USB on restart. Makes me wonder if the drive isn't being properly powered down or something. –  rabid.sloth Jan 5 '12 at 6:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.