Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, I upgraded to Firefox 4 and when I sign out of Hotmail, it says: Couldn't sign you out

We couldn't sign you out because your browser is blocking cookies. To sign out, close all of your browser windows.

Is this bad? And how do I stop it happening in the future?

Thanks for helping a new guy... Ben

share|improve this question

1 Answer 1

Did you disable cookies in Firefox settings (Options => Privacy) or use any cookie blocking add-on? Alternatively you might browse in safe-browsing mode.

If yes, then this message seems not to be harmful. Web pages are used to save cookies in your browser in order to persistently save authentication. So when you close your main browser windows and re-open a new browser instance you would not have to log in again. In case you disabled cookies your browser will also not allow to destroy such authentication cookies on purpose. But this can be silently ignored as there is nothing to be deleted.

You can check all cookies stored by your browser in the Options => Privacy screen in Firefox. It also allows you to delete specific cookies.

You can also try the following:

  • Log in to Hotmail
  • Just close your browser
  • Re-open your browser and go to the Hotmail page

If cookies are enabled you're likely to be still logged in. If cookies are disabled you're likely just facing the login screen again.

So if you don't have cookies this might reduce the usability slightly and enforce you to log in more frequently. Remember that other pages might store different things in your cookies (like shopping cart contents or similar stuff). I usually do not recommend to switch off cookies in general nowadays.

share|improve this answer
    
Cookies are allowed. "But this can be silently ignored as there is nothing to be deleted." So I should just ignore it? Thanks. x –  bdraus May 28 '11 at 0:03
    
Well, I meant it can be ignored if you disabled cookies. If you allowed cookies and you're not using any add-on which could block cookies, then you should probably check what's wrong unless you're running in "Private Browsing" mode. You might also use "about:config" and look for custom "cookie" settings. –  SkyBeam May 28 '11 at 0:20
    
"then you should probably check what's wrong" - yup, thats what I'm trying to do :[ No add-ons and I've allowed cookies; I'm not in Permanent Private Browsing mode either. So, what is "about: config"? Thanks sincerely for your help –  bdraus May 28 '11 at 0:37
    
just type "about:config" in your address bar and hit enter. Then confirm the warning and enter "cookie" in the search bar. Reset all properties you find to default values and restart your browser. You might also try running with a clean profile (see kb.mozillazine.org/Profile_manager) to check whether it's a setting issue (most Firefox issue come from screwed personal settings). –  SkyBeam May 28 '11 at 9:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.