Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sometimes the application buttons on the Windows 7 taskbar change position by themselves. For example, if I have two windows of the same application opened, the first opened window should be the first button on the taskbar (to the left of the other) and the second opened window should be the second button on the taskbar (to the right of the other), but they switch places sometimes. I don't like this. How can I fix / configure this not to get rearranged?

I am not using Aero, and the buttons of the same application are not grouped under a single button.

!

share|improve this question

migrated from stackoverflow.com May 28 '11 at 3:46

This question came from our site for professional and enthusiast programmers.

    
Are they alphabetized by name? Windows 7 alphabetizes the program start menu. Perhaps it is doing the same thing for the taskbar. –  wbeard52 May 28 '11 at 3:53
    
With what application has this happened to you? I have seen it (notably) with the SeaMonkey web browser. –  therube May 28 '11 at 5:51
    
It happens mostly with eclipse, but that has nothing to do with the rearranging (i think) –  Tchypp May 30 '11 at 6:30

1 Answer 1

You may want to try enabling the classic Windows XP style 'Quick Launch Bar'. Steps are:

  1. Right click on a blank area of the taskbar and select 'Properties'
  2. Select 'Use small icons'
  3. Under 'Taskbar buttons' select 'Combine when taskbar is full'
  4. Click 'OK' to save the changes
  5. Right click on the taskbar, select 'Toolbars' then 'New Toolbar...'
  6. Under 'Folder' enter in "%appdata%\Microsoft\Internet Explorer\Quick Launch" and click 'Select folder'
  7. Right click on a blank area of the taskbar and un-tick 'Lock the taskbar'
  8. Drag the quick launch taskbar item to the left by selecting the dotted lines and dragging it all the way to the left.
  9. Make the quick launch taskbar item smaller by selecting the dotted lines at the end and dragging it tot he left until it's a good size
  10. Right click on the 'Quick Launch' words and un-tick 'Show Text'
  11. Right click on the 'Quick Launch' words and un-tick 'Show title'
  12. Right click on a blank area of the taskbar and select 'Lock the taskbar'
  13. Right click on any remaining "pinned" programs and select 'Unpin this program from the taskbar'

Source: Windows 7 – How to enable the classic Windows XP/Vista task bar

Source is a personal blog I run.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.