Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

What could be the possible solution to solve this problem in my fedora 11 pc which is not allowing any users to connect to it via ssh? But the reverse is possible, i.e. i am able to connect to other PCs from this problem PC via ssh.

This is the out put i see:

[root@myFedoraPC]# ssh [email protected]
ssh: connect to host 10.47.5.100 port 22: Connection refused

Please help.

Thanks,
Sen

share|improve this question
    
Are you sure you a) installed openssh-server and it is running and b) that you aren't running the built-in firewall? –  slhck May 28 '11 at 10:25
    
how to check if openssh-server is running or not? –  Sen May 28 '11 at 11:25
    
i have already disabled firewall.. –  Sen May 28 '11 at 11:26
    
@Sen Try service sshd start and see what it outputs. Also see this answer –  slhck May 28 '11 at 11:28
    
Actually it was a problem with my /var/empty directory. It had full permissions, which was not allowed. –  Sen May 28 '11 at 13:01
show 2 more comments

1 Answer

Just went to / path.
Checked the permissions and found that someone has given the /var directory full permissions(0777 mode).

Went into superuser mode and changed the /var permissions to "0755".
And everything was working fine.

Thanks for all your helps.

Sen

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.