Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used to be able to type

cd $home/p

hit the tab key and the command would change to

cd /home/phill

Now it doesn't. When cd'ing to a directory based on an environmental variable, I'm "flying blind" now which is annoying. I know this feature exists because it was fine on my old Debian 5 machine.

I'm using Debian 6 stable. I installed the bash completion package which allows to complete partial environmental variables but that isn't what I want. Unfortunately talk of that feature is clogging up results on Google.

Help would be very much appreciated.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I just diffed my two bash_rc files. Turns out I need to delete the section that sources /etc/bash_completion, that is, to NOT use bash_completion extensions.

share|improve this answer
    
Good to know. Thanks for reporting :) –  SkyBeam May 28 '11 at 15:33
    
Is there any way to make it work w/o needing to disable all the useful completions provided by /etc/bash_completion? –  BeeOnRope Aug 17 '11 at 2:32
    
Sorry, I don't know. I think that requires a fresh post. –  Philluminati Aug 23 '11 at 10:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.