Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a TV tuner card with its output connected to the CD in of an integrated sound card. Video is OK, and the sound also gets thorough (to the line out) when running xawtv, for example. However, I found no ways yet for recording it.

I'm running Ubuntu 10.10 with ALSA drivers. Pulseaudio was running in the beginning, now it doesn't, but it doesn't seem to make much difference.

Some things I've already tried:

  • capturing with VLC, using plughw:0,0 as the audio capture device. (Result: no sound track at all in the resulting video.)
  • arecord, then aplay.
  • alsamixer. The capture source is set to "CD" (and on the input side it's also "CD" where I can effectively modify the volume for audio going through...), but still no result.

Do you have any ideas what else could I try? (I seem to have run out of them...)

share|improve this question
add comment

3 Answers

From my experience with ALSA on Natty (11.04), you can get a list of the input devices with the command arecord -l (dash lowercase-L). I've used this successfully to identify the ALSA device for my capture card (pcHDTV HD5500) and play live TV with sound from the analog capture using mplayer:

mplayer tv://6 -tv alsa:adevice=hw.2,0:immediatemode=0:audiorate=32000:forceaudio

where the hw.2,0 came from the output of arecord -l (it listed "card 2: CX8801 [Conexant CX8801], device 0: CX88 Digital [CX88 Digital]", thus "2,0"; you want the "hw" device for this, so it should be "hw:2,0" for ALSA, but mplayer wants the colon replaced with a period).

To my chagrin, I do not know how to reproduce the effects of these settings in MythTV. I would welcome some help with that.

share|improve this answer
    
Upon further fiddling, I found that replacing "hw" in the ALSA device spec with "plughw" gives me sound from the analog tuner. I can also use the string name, so now the audio device ALSA:plughw:CARD=CX8801,DEV=0 works for me. –  ReWrite Jul 30 '11 at 17:30
    
thanks, this seems to be a good way to list ALSA devices (works for me too), and I also ended up using mplayer/mencoder –  Latanius Dec 28 '11 at 11:35
add comment

I've used MythTV for recording TV on Ubuntu in the past and it works quite well. You can get some workable configurations on https://help.ubuntu.com/community/MythTV

One year back, I had seen it working at a cable TV operator and it worked pretty well.

share|improve this answer
add comment
up vote 0 down vote accepted

After another round of experimenting, here is the answer: buy a better sound card.

As it turned out, the integrated sound chip on my motherboard had a buggy linux driver that wasn't able to record audio at all. Under Windows, it worked somehow, but probably this was the reason for the half-second delay between video and audio there... (upgrading to Ubuntu 11.10 didn't help, either.)

Everything works perfectly now with an SB Live!, bought for $12... What I use is:

mencoder tv:// -tv driver=v4l2:alsa=1:adevice=hw.1:norm=PAL-BG:input=1:width=768:height=576 (...)

(the rest of the line is only about output codecs and filters.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.