Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a macbook 13" for about 3 years now, and last weekend I decided to format the disk and reinstall everything.

Turns out that after reinstall Leopard, install all available updates, and connect my LG 22" TV/Monitor, that used to works just fine at 1680x1050 before, Leopard does not recognizes such resolution anymore and all the available options look so much bad. I do need 1680x1050, that should be the native resolution of this TV/Monitor.

Anyone knows something I can do to fix this? A config file to edit, something to install?

This is not the first time I format this macbook exactly the same way, and it never has happened before.

share|improve this question

migrated from Aug 24 '09 at 19:52

This question came from our site for system and network administrators.

Try SwitchResX, a utility for handling this sort of problem. I haven't used it deeply, but it did solve a one-time monitor resolution problem I had. Good luck!

share|improve this answer

The only other thing that really comes to mind is to reboot your computer with the monitor connected. That helps when the monitor isn't identified at all (as does hitting the "identified displays" button in the Displays section of System Preferences.) I assume that you don't have the monitors mirrored, do you (in which case, the best resolution you can use will be the highest one supported by both monitors).

share|improve this answer
I've already tried this. No matter what I do, the native resolution of the monitor is never available. The highest one is 1920x1080, which is not supported by the display. The other ones are too small. Thanks for the reply. – Rafael Romão Jun 4 '09 at 15:02

I had a similar issue and the solution was to replace the original monitor with one that supported a higher resolution and the issue was resolved.

share|improve this answer

You must log in to answer this question.