Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Problem Description:

Windows 7 Ultimate on Hyper-V Virtual Machine hosted by a 2008 Server R2 SP1.

It was running last night under my account "Foo" when an automatic reboot had occurred due to Windows Update running overnight. I was presented with the welcome screen but the user account Foo is no longer displayed as a logon option, just Administrator.

Details:

Windows Update installed these 2 updates: KB2533552 and KB2534366. Subsequent reboots did not fix the issue.

I can see the account Foo in Computer Management/Local Users and Groups and it looks normal (is not disabled), but I don't see it in Control Panel/User Accounts and Family Safety/User Accounts/Manage Accounts. All I see there is Administrator and Guest (off). The profile folder is still there.

I don't feel comfortable doing what is recommended here. Besides, C:\Users\%username% or C:\Users\Temp do not exist on this machine.

Things here look normal: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList - no keys with .bak extensions.

When I try a system restore to a point before the Windows Update I get "System Restore did not complete successfully..." "The file or directory is corrupted and unreadable".

Any ideas on how to make the Foo user account show up again so I can log on with it?

share|improve this question

I'd first run a chkdsk /f on the drive to make sure the file system is still good. Then try this (source):

I managed to fix it by deleting a key from the registry. Click the Start menu and type regedt32. Navigate to the following key.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList In the profile list, there was one named .DEFAULT with no data within it. I deleted this key rebooted and all of my user icons were back on the logon screen.

Of course, you should have a backup of the registry key before deleting. I don't know why this suddenly changed. Hope this helps!

share|improve this answer
    
Thanks Randolf. I did a chkdsk /f on the Hyper-V host machine (no disk problems found), chkdsk doesn't seem to be allowed to run on the VM directly. Rebooted, no change in behavior. – Tim Tonnesen May 28 '11 at 23:37
up vote 0 down vote accepted

I discovered that the "Foo" account lost it's membership to the Administrators group. This is what got changed, apparently, by Windows Update. Once I added Foo back in to the Administrators group it appeared back on the welcome screen.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .