Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an external hard drive which worked fine and it is my backup harddrive. There are also some files on it that I would really want to keep. It's a 400GB Freecom drive in FAT32.

All of a sudden, after not using my HDD for a week or 6, a message pops up with: "You need to format your disk in drive X".

I tried a couple of solutions that I found, but they give different results:

  • sfc /scannow in the command line tells me that everything is fine. All drives work great.
  • I checked 'Disk Management' and deleted the hard drive letter and added it to another one. Didn't help.
  • I checked the hard drive on another PC, same message.
  • I did a Deep Search in Recuva. It only returned 50 mb of files.
  • I ran an analyse in TestDisk. It returned that there are no partitions found on the hard drive. 'Disk Management' does say that there is one primary partition.

Did I do something to my HDD in the meantime? No, it was just laying in a clean drawer. Could somebody please tell me what is wrong with my external HDD?

share|improve this question
2  
It could be that it is telling you that FAT32 on a 400GB drive is a bad idea, and that you should move to NTFS (which is true, there are a lot of advantages, etc). You don't have to though. –  soandos May 28 '11 at 23:46
    
@soandos: Yes I know I should, but I didn't know that when I bought this hard drive a year ago. But still, my files seem to be corrupted or something. –  Marnix May 28 '11 at 23:51
    
What do you mean corrupted? Are you having issues reading from the drive? –  soandos May 28 '11 at 23:52
    
@soandos: I mean that explorer doesn't want to open my external HDD, it just tells me that it has to be formatted first. –  Marnix May 29 '11 at 9:22
    
Try with a different file explorer or OS. There is no reason to go and spend hundreds of dollars (usually) to recover data if you dont have to. Have you tried chkdsk? –  soandos May 29 '11 at 11:37

2 Answers 2

up vote -2 down vote accepted

The error which you are getting is common error faced by lots of users and in this situation TestDisk helps out. As you already try this so, I suggest you to avoid do something with hard drive and simply use a good data recovery software to recover data from hard drive. First try demo version of software that will show you all recoverable data then buy it after satisfied with preview of recoverable data. After a successful recovery of data you can formate your hard drive.

share|improve this answer
    
I downloaded a demo of Data Recovery Wizard (I think that's its full name) and I'm running it right now. We'll see what happens next. It still needs 5 hours to run =) –  Marnix May 30 '11 at 10:04
    
Data Recovery Wizard did what it had to do. Got all my files back!! –  Marnix May 30 '11 at 16:26
    
@Marnix: Can you please clarify, have you recovered all your files? or need to explain how can we recover data through the stellar data recovery software? –  user82711 May 31 '11 at 4:20
    
I have everything back. I think the FAT was just corrupted, but the files were all ok. So I have it all back now. –  Marnix May 31 '11 at 16:50

First, stop trying to recover the files yourself and talk to a data recovery service. They're your only hope. If you keep messing with the drive you're going to make their job that much more difficult and expensive.

If your drive doesn't work on another PC then it has most likely suffered a hardware failure. I've seen this happen many times. It's nothing you did, these things just happen especially to cheaper brands like Freecom.

BTW, "sfc /scannow" has nothing to do with data recovery. It scans your Windows installation for corrupt or missing system files.

share|improve this answer
    
That's a shame. Thanks for the advice. I don't think my data is that important. Do you think that I can use my drive again after formatting? Or do you suggest buying a new one? –  Marnix May 29 '11 at 9:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.