Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm working in Debian, and I've noticed that when I resize my PuTTY window, the console inside isn't resizing to the new dimentions, so things like nano are running at 80xwhatever instead of the more useful 130xsomething that I've offered it.

Does anyone know how to fix this?

share|improve this question
up vote 2 down vote accepted

Console apps can usually be told to forcibly refresh display: in most cases, it can be done by hitting Ctrl-L. You might also want to check PuTTY's settings, to make sure that you don't have remote terminal resizing disabled by default.

share|improve this answer
The "Remote terminal resizing" feature is for server-initiated resize (e.g. printf "\e[8;%d;%dt" 40 50). It doesn't affect what happens when the user resizes the window themself. – grawity May 29 '11 at 17:02
Ah, cool. Thanks for the clarification. – Neil Santos May 31 '11 at 12:05

Check your shopt settings

shopt -s checkwinsize
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.