Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After I restarted my computer, I find that Windows 7 has added a watermark to the wallpaper at the right bottom corner. It reads:

Test Mode
Windows 7
Build 7600

This is legal copy of Windows 7 and I have already been using it for more than a year. Why is this watermark showing up now? How do I get rid of it?

share|improve this question
2  
Open a (read: elevated) command prompt and type in bcdedit. –  Hello71 May 29 '11 at 14:13
    
Hello71: Can you repost your comment as an answer so that I can accept it? –  Ashwin May 29 '11 at 14:20

3 Answers 3

up vote 4 down vote accepted

It looks like either you or any program has set your Windows 7 into test signing mode. This is typically done if you need to install an unsigned driver. As Windows 7 does not allow to install unsigned kernel-mode drives (unsigned/untrusted user-mode drivers are allowed) you need to enable "testsigning" mode in order to install it.

To verify whether you're running in testsigning mode open up an elevated command prompt and type:

bcdedit.exe

Then look at the Windows Boot Loader section and check for testsigning parameter. It might look as follows:

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 7
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {fa491940-8aab-11de-99e7-fd0bcc610d86}
recoveryenabled         Yes
testsigning             Yes
osdevice                partition=C:
systemroot              \Windows
resumeobject            {fa49193e-8aab-11de-99e7-fd0bcc610d86}
nx                      OptOut
debug                   No

To disable testsigning mode type the following on an elevated command prompt:

bcdedit -set TESTSIGNING OFF

Now the testsigning line should disappear or read No:

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 7
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {fa491940-8aab-11de-99e7-fd0bcc610d86}
recoveryenabled         Yes
testsigning             No
osdevice                partition=C:
systemroot              \Windows
resumeobject            {fa49193e-8aab-11de-99e7-fd0bcc610d86}
nx                      OptOut
debug                   No

Caution: If you have recently installed an unsigned driver or connected a device which comes only with unsigned drivers then disabling testmode might break the device or render it useless as the driver will not be loaded any more.

If you do not have any clue what could have enabled testmode you're strongly advised to run antivirus and anti-rootkit tools like GMER. Recently a rootkit was revealed which silently enables test mode in order to install unsigned drivers into the Windows x64 system (32-bit versions of Windows are not that strict and allow drivers with invalid signature to be loaded in kernel-mode).

share|improve this answer

Open a (read: elevated) command prompt and type in bcdedit.

If the option you're booting from (likely there's only one) has "Test Signing" or such enabled, disable it.

bcdedit /set testsigning off

should work nicely.

share|improve this answer

Here is a Microsoft posting that gives the exact syntax for the bcdedit method the commenter mentioned. You need to turn off the "Test signing" mode.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.