Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While installing cygwin I'm getting the following error

unable to get setup.ini

What is the reason?

I'm newly studying Unix. So Please guide me in this.

share|improve this question

migrated from May 29 '11 at 15:25

This question came from our site for professional and enthusiast programmers.

How you try to install cygwin and which Linix? – Kiril Kirov May 29 '11 at 15:21
@KirilKirov: There is no Linux involved; Cygwin is a Unix-like environment for Windows. – Keith Thompson Oct 25 '11 at 18:24

I had to switch from setup.exe to setup-x86.exe or setup-x86_64.exe.

share|improve this answer
This worked for me too. Just went to and downloaded setup-x86_64.exe and it ran perfectly. Thanks! – Nathan Wallace Aug 6 '13 at 13:24
Cygwin recently changed the formatting of their mirror's folder structure to support both x86 and x64. Because of this setup.exe downloaded before this change no longer work due to them looking for the ini at\cygwin where the new location is\cygwin\x86 – Scott Chamberlain Aug 8 '13 at 4:35
And here are the direct links for setup-x86.exe and setup-x86_64.exe as of 2013-10-23. – wil Oct 23 '13 at 8:34

I think you just need go to [] to download the latest setup.exe file. actually, the error msg tells you that it can not find the setup.ini file, yes, the setup file changed the location.

share|improve this answer

I was getting the same problem, when I selected "Direct connection to internet", then I did change it to "Use Internet Explorer Proxy Settings" and it worked so good... try and let me know..

share|improve this answer
Same here. Probably attributed to my being behind a corporate firewall. – urig Dec 5 '11 at 14:53

I was having this problem when running setup.exe from a network drive. When I copied setup.exe to my local drive, it ran correctly.

share|improve this answer

The setup.exe installer lets you select one of several dozen download locations (mirrors). The setup.ini file is downloaded from the mirror you select. If that fails, the first thing I'd try is to pick a different mirror.

It's also possible that you need to change the proxy settings (direct connection vs. IE proxy settings), as others have mentioned.

share|improve this answer

Try -X on the command line to setup.exe, worked for me.

The "Use Internet Explorer Proxy Settings" did not work for me.

share|improve this answer

What is the URL that follows that message ? Is there any ?

Doing a quick search on google I found that broken URLs causes that message.

See, for instance:

If you get the error message Unable to get setup.ini from http://prc-tools[...], check the URL you added and add it again if necessary. Most people who have encountered this message have eventually found that it was caused by a mere typo, such as the addition of a trailing space to the URL.)

Try to download the URL directly in a browser. If you get 404 error, then you found the problem, and you should pickup another mirror download site on cygwin.

Also, I would really recommend installing Ubuntu sideways with Windows, if you're going to really study *nix systems.

share|improve this answer

You must log in to answer this question.

protected by Breakthrough Mar 22 '13 at 22:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?