Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Fedora 15, in GNOME Shell, my mobile broadband connection was working absolutely fine, until I set the connection type to Connect Automatically using nm-connection-manager. Now, when I start the Fedora, the Top panel network icon shows red exclamation symbol and when I click it, instead of showing me available networks' list, it shows only "Network Settings", and when I open it, it shows GNOME 3's new Network Manager app, and it pops out the dialog saying that, "Current network settings service is incompatible with this version". And after a few seconds of log in, the shell freezes and all I can do is log out using Ctrl+Alt+BackSpace.

I'm facing this problem since I opened old network manager app using nm-connection-manager in the run dialog, and editing my connection to connect automatically.

After logging in to the shell I somehow managed to delete that connection from the same app and created a new one, but the problem still exists. How can I delete all network preferences (by deleting its configuration files from my home directory or something like that) and reset the GNOME 3's network manager to its default state?

share|improve this question
    
Fedora 14 and 15 had a lot of little issues with the wireless drivers. Plus, Fedora 15 is a bit dated. Is it not possible to upgrade? (And I really miss Fedora 14. I beats the snot out of anything we have today with the tablet desktop managers - both Linux and Windows). –  jww Jun 22 at 2:25

1 Answer 1

I had exactly the same issue.

To reset the network manager settings, i found 2 places:

/etc/sysconfig/network-scripts/ and /etc/NetworkManager/system-connections/

In the latter was the mobile broadband connection file. just delete, then restart network manager with systemctl restart NetworkManager.service

I still did not figure out how to make the mobile broadband connection work however...

share|improve this answer
1  
Later I found that the problem surfaced due to an update of NetworkManager issued by Fedora. So, the new version of the package had the bug so only option we have to solve is to downgrade the package to older version. You may find more about the problem and possible solutions at this thread. The solution is quite long and complicated so I avoided to post it here, but I hope this comment help others who had same problem. –  Kush Jun 2 '11 at 15:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.