Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am wanting to extend my windows partition to occupy some unallocated space. When I use gparted in ubuntu it says there is something wrong with the file system and refuses to work the operation. But when I boot into the windows os that is on the partition I am wanting to change it will do it fine. Would it be a bad idea to use windows to partition the partition it is currently running on?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Not at all, I have extended and shrunk from Windows just fine!

I am a bit concerned that Gparted is having issues though... Possibly make sure you are using the latest version and/or do a can of the hard drive to make sure there are not any other errors.

share|improve this answer
    
Ok. Thank you. It is the only gparted I have that says that. The one in opensuse and fedora don't report any errors. I don't want to boot into them though because I am already in windows. Even though it will shift the os to the left it will still work? –  a sandwhich May 29 '11 at 21:57
    
Well, I ran a disk check in windows and the error went away in ubuntu so I decided to go ahead and partition from there. I did it, it said all operations completed successfully and I rebooted into my 7 repair disk like I normally have to do when shifting partitions so I can recover the boot files. Did that, went fine and all, but when I rebooted it said autochk program not found skipping autocheck, it bluescreened for a half second and restarted. Now i am going to attempt a diskcheck from within vista. –  a sandwhich May 30 '11 at 14:45
    
I don't know why you didn't extend from Windows - it is much safer –  William Hilsum May 30 '11 at 16:12
    
Well then. I was unaware, I normally do my partitioning with gparted in ubuntu and everything has worked fine so far. I just posted another question about this problem. The diskcheck in vista didn't report any problems. –  a sandwhich May 30 '11 at 16:15
    
I have tried to answer your other question... not very well :/ but hopefully it will put you on the right track. –  William Hilsum May 30 '11 at 16:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.