Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Right now I have this setup:

/dev/sda1 is NTFS where I store my cross-platform accessible pictures/videos/etc.
/dev/sda2 is my Windows 7 boot partition

/dev/sdb1 is ext4 partition with Ubuntu 11.04 mounted at /
/dev/sdb2 is my swap partition
/dev/sdb3 is my /home partition

Problem is, when I boot, Grub (I think it's grub, at least) wants to automatically boot from /dev/sda1 but freaks out when it senses NTFS so it sends me to grub rescue mode where I follow this guide and get it to boot from /dev/sdb1.

I've set my BIOS boot order preference to prefer hd1 over hd0, but that doesn't help. I've also run sudo update-grub to see if I just needed to update grub after making all these new partitions and such.

Any ideas how to remedy this? I'd love even a grub menu over immediately booting into grub rescue mode.

share|improve this question
add comment

1 Answer

Create a Custom Menu in Grub2. The guide for this can be found here: https://help.ubuntu.com/community/Grub2 under 7. Custom Menu Entries. You can add '#Custom Menu Entries' after the link I gave you to get to the correct place on the page.

A sample entry might look like:
menuentry "My Default Karmic" {
set root=(hd0,1)
search --no-floppy --fs-uuid --set cb201140-52f8-4449-9a95-749b27b58ce8
linux /boot/vmlinuz-2.6.31-11-generic root=/dev/sdb1 ro quiet splash
initrd /boot/initrd.img-2.6.31-11-generic
}

After you've made and tested your custom menu, you can make it the default choice by editing the GRUB_DEFAULT option in /etc/default/grub.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.