Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got AT&T U-Verse set up. Everything's fine except that my Macbook Pro and my daughter's Macbook Pro lose wireless connection every 15 minutes or so. When that happens, I can't ping to the router (192.168.1.254). I have to turn AirPort off and turn it on, then it starts to work again. But connection is lost again later.

So far, my Windows 7 laptop seems ok.

After some research, I changed the following things but no luck.

  1. I disabled 'Wi-Fi Protected Setup' in the router.
  2. I changed the wireless channel to 9 from auto.
  3. I set DNS to outer server not the router
  4. I turned off IPv6 on my Macbook Pro.

Has anybody experienced this problem?

share|improve this question
    
Having identical issue. Wifi works for 10-15 mins then connection is lost. Rebooting airport gives you another 10-15 mins. Called tech support and they did some temporary fix about 3 weeks ago but now back to the same behavior, calling again now. –  Uverseughs May 31 '11 at 1:48
    
My iPad2 also has a problem with this wireless network. Same symptom. I guess all Apple products have an issue with U-verse. –  Sam Kong Jun 1 '11 at 4:06

1 Answer 1

up vote 1 down vote accepted

Have identical issue. Wifi works for 10-15 mins then connection is lost. Rebooting airport gives you another 10-15 mins. Called tech support and they did some temporary fix about 3 weeks ago but now back to the same behavior.

Just called again:

  • I went through two techs, first one was friendly but not that knowledgeable. second (Justin) seemed to know more. says it is a mac-specific issue that others have and is not router specific.

  • One possibility is to change the channel your wireless router broadcasts on, by going to

http://192.168.1.254/xslt?PAGE=C_2_1

he couldn't guarantee this would help at all but he said give it a shot.

  • Also he changed security from WPA to WEP-open
share|improve this answer
    
Thanks for sharing. I already changed the channel and it didn't help. I'll try WEP-open. –  Sam Kong Jun 1 '11 at 4:04
    
I changed it to WEP-Open and it's been ok so far. Yeah~ Thank you very much. –  Sam Kong Jun 1 '11 at 22:05
    
May wish to put an inexpensive router in the DMZ of your 2Wire device and disable wireless on the 2Wire device itself to avoid relying on WEP-Open as your encryption method. –  RobPaller Jun 8 '11 at 13:04
    
How do I change from wpa to wep? –  user113641 Jan 14 '12 at 17:22
    
Having this exact same problem - I switched both the channel and the security from WPA to WEP-open, hopefully that works. Advice for anyone else who tries this: connect to Ethernet first! If you change your wifi settings while you're on wifi, the connection drops when the new settings are applied and then can't pick back up because it doesn't know what they are ;-) –  daGUY Mar 28 '12 at 15:47

protected by random Jan 14 '12 at 17:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.