Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Ubuntu 10.10 and Google Chrome. After upgrading from Chrome 10 to Chrome 11, the printing changed from opening the standard Gnome print dialogue to reopening the page in a browser with a sidebar with print settings.

The print button on that sidebar has never worked for me. If I press the button nothing happens. Printing in Chrome 10 worked fine. Has anyone else had this issue and found a workaround?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

On the Windows Build of Chrome, Printing has not changed at all, but, I had the exact same issue you are having after going in to about:flags and enabling Print Preview.

After disabling this option, it went back to the bog standard print.

If you did not do this, let me know and I will delete my answer.

share|improve this answer
1  
This worked! I think me messing with those settings might have been what caused the issue, not the Chrome 11 upgrade. I faintly remember poking around in the about:flags around the same time the 11 upgrade came in. :) –  Sindri Traustason May 30 '11 at 17:36
    
hehe, @Sindri... I thought Chrome had broken something as well as I hardly ever do printing... Took me a while to realise it was me that messed it up! Glad it worked out for you... Some of those about:flags options are very tempting! –  William Hilsum May 30 '11 at 18:14
add comment

I did not know about that problem in Chrome. I may suggest you to use Chromium, the open-source browser which shares Chrome's code base. You can do that by installing the package chromium-browser. If you'd like a newer version, you can add chromium's daily build PPA to your system.

sudo apt-add repository ppa:chromium-daily/ppa
sudo apt-get update
sudo apt-get install chromium-browser chromium-browser-l10n chromium-codecs-ffmpeg-extra flashplugin-nonfree

Hope that helps, don't forget to remove Chrome before that (settings, bookmarks... are kept). I use these chromium builds everyday (chromium 13 now), it is really stable (except flash :). The printing dialog works for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.