Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using gVim to type in a journal paper that contains a lot of occurences of the unicode characters U+0219 "s with comma below" (ș) and U+021b "t with comma below" (ț).

Both encoding and fileencoding are set to utf-8, and the GUI font I'm using, Consolas, clearly supports these characters, yet Vim shows them on screen as question marks. That wouldn't bother me too much, except it saves the file to disk with the question marks as well!

Update: Looks I can paste the character into Vim from clipboard, I just can't type it. I'm using the "Romanian (Programmers)" keyboard, and ș is bound to AltGr+s, or Ctrl+Alt+s. Could there be some keybinding conflict with gVim on Windows?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I think :he mbyte-keymap may be the answer to your problem - this has an advantage that normal mode is not using the alternative layout.

Surprisingly there is no Romanian keyboard shipped with vim, so you can use one from here

Then just set:

set keymap=romanian
share|improve this answer

It is possible to use correct diacritics characters on Windows XP, 7 by hacking Windows XP and Windows 7.

Namely using the ISO-8859-16 (code page 28606) from ReactOS and setting it as ISO-8859-2 (code page 1250).

I've described the technique and I've put screenshots here: http://groups.google.com/group/diacritice/msg/2cac27bfd2269cb4

I've also put a video tutorial which shows how to do this on Windows XP: http://www.youtube.com/watch?v=X_q8H-dd1KI and on Windows 7: http://www.youtube.com/watch?v=oqyAEFEpZlg

Bonus you will get emacs and putty working too!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.