Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Ubuntu 11.04, Network Manager + vpnc + resolvconf. I have some VPN and wired connections configured in Network Manager.

Whenever I connect to the VPN my /etc/resolv.conf gets populated with the VPN's DNS nameservers in front of the eth0 record. However after five minutes or so, the eth0 connection's nameserver becomes first in the list.

How can I disable this kind of behavior?

share|improve this question
    
Did you solve this problem yet? I have an answer below that might work. –  Pykler Mar 30 '13 at 3:32

1 Answer 1

Add the following to your vpnc config (if using the command line, edit it through the gui for Network Manager)

DNSUpdate no

http://ubuntuforums.org/showthread.php?t=1623624

And manually add your dns entries

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.