Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Windows on my new SSD and for about a day I had a HDD connected to the computer. I moved the page file to the HDD, but at some point I decided to ditch the HDD altogether and put it in my server.

However since I forgot to remove the page file from the HDD, every time I start Windows 7 it gives me an error that it was unable to create a page file on the preconfigured HDD, so it will automatically adjust it itself.

Is there a registry key or something else I can edit so that it stops trying to make a page file on a non-connected HDD?

share|improve this question
Have you tried changing the location of it back to the SSD in system properties? – Moab May 30 '11 at 16:03
up vote 2 down vote accepted

You can change the location back to the SSD drive using Windows 7's Performance Options.

  1. Hit Windows + Pause Break keys
  2. In the left pane, click on Advanced system settings
  3. Click on the Advanced tab
  4. Click on the Settings... button in the Performance section
  5. Click on the Advanced tab
  6. Click on the Change... button
  7. Highlight the drive you want to work with

It's recommended that your page file size equal your RAM size.

share|improve this answer
Well I don't want a page file since I have enough RAM and I only use the PC for gaming. But that kind of worked. I set the page file back to the SSD drive, restarted and removed the page file and now no error pops up. Thanks. – xciter May 30 '11 at 22:06
@xciter: I've heard that not having a Page file in Windows 7 causes issues. I prefer to leave it alone. I'll give you this link that talks about why you shouldn't disable the Page file.… – Chris Ting May 31 '11 at 0:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .