Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Skype on Debian and ran it headless, however, I cannot interact with it over dbus.

Some context of what I have so far:

  • Installed Debian 6 on VMware fusion box from netinst CD
  • Skype version is 2.2.0.25 dynamic
  • DBus version is 1.2.24, installed it with apt-get install dbus
  • Skype seems to be running fine in headless mode

What seems odd:

  • When starting Skype with Skype --enable-dbus --use-system-dbus it shows warning Skype: unrecognized option '--enable-dbus'

Now when I try to send some messages to Skype over dbus with this:

dbus-send --system --type=method_call --print-reply --dest=com.Skype.API /com/Skype com.Skype.API.Invoke string:NAME\ hello  string:PROTOCOL\ 5 string:SET\ PROFILE\ RICH_MOOD_TEXT\ echo123

It ends up with error message:

Error org.freedesktop.DBus.Error.ServiceUnknown: The name com.Skype.API was not provided by any .service files

When it comes to dbus, I'm new to it. As far as I understand, there should be some files under /etc/dbus-1/session.d|system.d but these directories are empty.

share|improve this question
    
I saw the same error messages (unrecognized option and ServiceUnknown) but dbus still seems to work. Did you try Skype4Py: import Skype4Py then skype = Skype4Py.Skype()? For me this worked (after installing dbus-x11) –  Philipp Keller Mar 7 at 16:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.