Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I currently have two computers connected to a KVM. One of the computers is connected to a spare display. Both computers are connected to an audio mixer. The KVM has DVI for video, and USB for the keyboard/mouse.

Anyway, sometimes I will start up a movie/video on the computer with the spare display, and put the window on the spare display, and then with the KVM switch to the other computer. Once I switch to the other computer Windows decreases all the audio volume for some reason, so the video which was playing great is barely audible.

Is there any way to disable this behavior, so I can have a video running on one computer, and be playing a game, or doing something else on the other?

The behavior seems to have nothing to do with the model of KVM attached since I have seen the behavior on 3 different KVMs, but since all the comments I have have gotten so far bring that up, I have included links to the models below. To repeat, I am NOT using the KVM audio ports, I have the audio from the computers directly routing into a mixer.

The audio does not return to the levels when I have reselected the computer. Here are some captures of the mixer before and after the switch. After a KVM switch I have to manually adjust the Windows mixer settings to get audio back to the normal level.

The Windows mixer before a KVM switch.

KVM Before switch

The Windows mixer after a KVM switch.

Mixer after a KVM switch


Ok, I have an update with an additional fact, but I really don't understand why it should be making a difference. The audio output from the on-board audio device in my computer is connected the mixer. Additionally, I have the USB audio adapter that comes with a logitech USB headset. I have a microphone connected to the adapter. So if I disconnect that adapter the audio levels do not change when I use the KVM to switch between computers. With that adapter connected, when I switch between computers the audio to the speakers drops to nearly 0, but not quite.

In the computer I have the on-board audio. I also

share|improve this question
    
Its quiet difficult to say without proper make and manufacture of the kvm switch, please provide complete details about the model you are using, you can find more about kvm switch at Smartvm.co.uk. –  user83929 Jun 1 '11 at 5:57
    
Since the audio is not going through the switch, why would that matter? Also, I have duplicated the behavior with a couple different KVM switches. –  Zoredache Jun 1 '11 at 16:19
    
Does the volume return to the proper level when you switch back to the computer playing video? –  Dustin G. Jun 5 '11 at 21:05
    
@Dustin G, unfortunately no, the audio is not restored when I reselect the computer. I have included some pictures of the Windows mixer. –  Zoredache Jun 6 '11 at 15:40
add comment

2 Answers

up vote 2 down vote accepted

I believe I have finally figured this out.

Apparently Windows 7 included a new feature to adjust the volume if you have communication software installed and the application decides there is a call taking place. The settings are found in Control Panel -> Sound -> Communications.

Apparently several different applications can trigger the volume changing like skype and steam both of which I happen to have running on my system.

I am still not entirely sure why it happens, but when I use the KVM to switch to different computer Steam seems to decide that everything else on my computer needs to have the volume muted by 80%. If I don't have my USB microphone connected, this doesn't happen. I suspect this may have something to do with the fact that the inexpensive KVM I have basically perform a USB disconnect of the keyboard/mouse, and that causes something to get confused and trigger the volume decrease.

I have disabled this 'feature', because it is not remotely useful for the way I use my systems, and I have not seen the symptoms any more.

Windows Communications Sound

share|improve this answer
    
dude, you're the man! I thought it was the KVM until I plugged the speaker directly into the back of my PC, and it still dropped volume when switching to the other PC. I think the root cause is that the KVM disconnects all USB (as my USB speaker soundbar cuts out completely). –  gbjbaanb Jan 19 '12 at 14:19
    
Let me re-iterate the thanks of the previous user; this answer is quite helpful. It's (incredibly) annoying to have the volume of my music change every time I swap to my mac to get work done. –  RonLugge Feb 23 '13 at 7:20
add comment

Based on the KVM's you listed, I suspect the issue is a result of their abilities to control the Windows Volume through hotkeys. All 3 KVM's can change the Windows Volume through hotkey commands. When you switch between systems, the KVM will send commands via USB / Keyboard emulation to reduce the volume in Windows.

The audio connections on these KVM's do not have the ability to amplify or lower the volume of the signal - they just pass the audio along and rely on windows volume control to handle audio levels. While you are not using the audio cables - it is still functioning as if you are using the audio switching feature and lowering the volume to avoid interference issues or a big surprise when you come back to the other system and are blasted by loud music etc.

I recommend purchasing a KVM that does not have audio switching abilities.

EDIT: I would also avoid USB audio devices, such as your mic as it appears as an sound card and may further introduce issues like what you are experiencing.

share|improve this answer
    
Interesting theory. I should be able to confirm this by finding and running a tool that will capture and log all the scancodes Windows receives. Now I just need to find a tool which will do this. –  Zoredache Jun 6 '11 at 15:48
    
If the KVM installed any drivers you may want to try to disable them and see if it still works and/or affects the audio. –  techie007 Jun 6 '11 at 20:50
    
Does your current KVM have a manual switching button? If so, you could leave the VGA / DVI connected and disconnect the USB, if you switch and the volume does not decrease - then you know the volume commands are being sent via USB... –  Dustin G. Jun 7 '11 at 2:34
    
@Zoredache - Any updates? –  Dustin G. Jun 9 '11 at 1:51
    
Sorry, for not giving an update earlier. Ues, I just discovered an additional detail. The symptoms only seem to appear when I have a USB microphone adapter connected. Without the USB adapter connected, I do not experience the problem. –  Zoredache Jun 9 '11 at 5:49
show 7 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.