Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like to use the TTF Consolas with aterm on my Ubuntu system. I've placed this font in my ~/.fonts directory, and I'm currently using it with emacs and gnome-terminal. So, I know some applications are recognizing it. I've added the following lines in my .Xresources:

aterm*font:-*-Consolas-Medium-*-*-*-14-*-*-*-*-*-*-*
aterm*boldFont:-*-Consolas-Bold-*-*-*-14-*-*-*-*-*-*-*

However, when I start aterm, I get the following message:

aterm: can't load font "-*-Consolas-Medium-*-*-*-14-*-*-*-*-*-*-*"

Is there something else I need to do to make aterm aware of this font?

share|improve this question
    
Why not using a more-modern terminal emulator like gnome-terminal or konsole? –  ilius Jun 11 '11 at 13:22
add comment

1 Answer 1

Apparently, aterm doesn't support TrueType fonts. I'm restating the claim made by people on other Linux support forums, I don't have any ready references right now.

As a long term user of Ubuntu/aterm myself, I've been also trying to get it to use Consolas or Inconsolata fonts. I did spend a fair amount of time tweaking various font settings via fontconfig and such.

BTW, how did you generate the font string above ? xfontsel doesn't list Consolas or Inconsolata. Did you create the string by hand ?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.