Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I started having issues with my terminal sessions for some reason that I'm not fully aware of how to fix. This is the terminal output that I get when I start up any new session now. RVM doesn't have anything for FAQ from what I could find. I've tried uninstalling RVM and reinstalling it. The only way I can get rid of it if I delete "[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" from my .bash_profile file.

-bash: /usr/local/rvm/scripts/log: No such file or directory
awk: can't open file /usr/local/rvm/lib/VERSION.yml
source line number 1
-bash: __rvm_conditionally_add_bin_path: command not found

I know that running step 2 of the RVM installation instructions

echo '[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" # Load RVM function' >> ~/.bash_profile

My ~/.bashrc code is this:

export PS1="\e[32;1m\][\W$()]\$\[\e[0m\] "

My ~/.bash_profile code is this:

alias ll="ls -al"

if [ -n "$PS1" ] ; then
  rm () 
  { 
      ls -FCsd "$@"
      echo 'remove[ny]? ' | tr -d '\012' ; read
      if [ "_$REPLY" = "_y" ]; then
          /bin/rm -rf "$@"
      else
          echo '(cancelled)'
      fi
  }
fi

source ~/.bashrc

PATH="/Library/Frameworks/Python.framework/Versions/2.7/bin:${PATH}"
export PATH

[[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" # Load RVM function

Any suggestions on mitigating this error?

I also changed Terminal to open with /bin/bash

share|improve this question
    
is this only when you open up a new terminal? or new terminal from another one... –  nictrix Oct 26 '11 at 13:10
1  
make sure you are setting the terminal as a login shell –  nictrix Oct 27 '11 at 12:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.