Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently reassembled my system , after getting replacement RAM, mobo and CPU from RMA. The computer ran fine - until I do something that utilizes graphics hardware spceifically, be it gaming or watching HD video through DXVA (mkvs in media player Classic Home Cinema). This results in crash to desktop, with a pop-up saying the ATI display driver crashed and had to be restarted, and the occasional hard freeze or bluescreen (where the bluescreen again points to ati[something].sys).

Thinking that the... incident.. that led to RMAing parts had also affected my graphics card, I replaced my 5830 with a 6870. And thought I was home free.. until my graphics driver crashed again, although I am able to keep gaming for longer periods of time.

My working theory is that I need to replace my PSU. The 5830 crashed after less gaming because it draws rather more power than the 6870. My other theory, which I feel seems less likely, is that the PCI-E port on the mobo is damaged somehow.

My case is well ventilated, and I had no such issues prior to RMAing parts.

So - do i pull the trigger on a shiny new Corsair HX 650W PSU? or is there another likely culprit?

System specifications:

  • 4x 2GB Corsair XMS3 1600mhz RAM
  • Intel i5-760
  • ASUS P7P55D-E LX P55 mobo
  • Scythe Mugen rev.2 CPU cooler
  • Corsair VX 550W PSU
  • Antec 300
  • Windows 7 Ultimate 64bit
share|improve this question
    
Are you sure it isn't a software issue? –  Cees Timmerman Feb 22 at 14:20
add comment

1 Answer

Use a temperature monitoring program to keep a close eye on the machine temperatures. Preferably something that will save logs so that you can see the readings right before the crash. This will properly eliminate overheat as the problem.

I think that if it isn't heat than the power supply is definitely where to point the finger. a motherboard failure is possible, but less likely, and it's a chunk less expensive to swap the PSU than the motherboard.

You could take a look at voltage monitoring to see if everything looks fine, but just because the voltages look fine when you check them doesn't mean they won't wander around when it's been under load for a while, causing hardware components to act strange. At least if the voltages are off when you check them, you know for sure the PSU is out of order.

share|improve this answer
    
Accepting this answer - even if it is for confirming my hunch :) –  Martin Andersen May 31 '11 at 4:59
1  
Update: My new PSU arrived today - and no change :/. Got lulled into a false sense of security playing WoW for 45 minutes - logged back in a while later, and the graphics driver restarted within 5 minutes. So, looks like it's the motherboard (PCI-E port? power regulators?) after all :/ bah - dconstructing a computer to RMA the mobo is such a bother. –  Martin Andersen Jun 5 '11 at 20:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.