Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to restart the X server with sudo /etc/init.d/gdm restart, and doing so brought me to a black screen with some messages I don't remember, and left me hanging like that. So I had to do a hard reboot. So now when booting I get to the ubuntu logo on the purple background and it just hangs like that. Doesn't accept keyboard input, I can't alt+d or ctrl+alt+f2.

I edited the ubuntu line in the grub menu and removed quiet but that didn't do anything. How do I diagnose this?

share|improve this question
Did it happen again? If so, what are the error messages? – soandos May 31 '11 at 6:23
That's what I'm saying, I can't see any error messages. And yes, it happens every time I boot – herpderp May 31 '11 at 6:31

I wish I could just leave this in a comment, however my reputation isn't high enough for that yet. Reboot and interrupt grub, edit the command line putting the word text at the end. This will boot you into a cli only mode. There are a great many possibilities of what could have gone wrong, however they can be narrowed by looking in /var/log and thumbing through the Xorg.* files. Look for your errors and comment back. The issue could be as easily resolved as just running

dpkg --configure -a

If that resolves it it was just an interrupted update of any number of packages Xorg is relying on, such as your graphics card's driver, or xorg itself. Another option is that it could be that your gfx card is going. If you comment back please also send the results of

lspci -k

(the only ones we need are the lines dealing with your graphics card the driver name. As another option you could select to boot into recovery mode from the grub menu if you prefer)

share|improve this answer
Even with higher rep, this is too long to fit in a comment. Plus it looks more like an answer than a comment to me anyhow. Maybe not a complete solution (yet), but at least it's a good way to proceed towards finding one. – Dave Sherohman May 31 '11 at 8:10
When i boot in the cli mode, the last line before it hangs is "checking battery state..." I had this exact problem earlier, where boot was hanging at that line; it was resolved when I switched my activated nvidia driver from version 173 to the current version. – herpderp May 31 '11 at 8:24
oh, and the gfx card is an nvidia geforce 9400 GT and the drivers are nouveau and nvidiafb. – herpderp May 31 '11 at 8:28
Hhhmmm, there's another option. Instead of booting in cli mode, in the past I've had to boot from an external medium, mount my root partition somewhere such as /mnt/temp, do a mount --bind for /dev, /dev/pts, /sys, and /proc, then chroot into the root partition to finish the dpkg --configure -a. If you give that a try, let me know how it turns out. Also, as a final measure, if the issue is something that goes in a different direction, you could try booting with a previous kernel version... However, you probably already tried that. – darkdragn May 31 '11 at 8:39
Actually booting from an earlier kernel does work. I recently upgraded to the pre-released 2.6.38-9, that's what seemed to cause the nvidia driver problem I just mentioned I had earlier. Anyway, so I boot with 2.6.38-8 and run dpkg --configure -a, but that doesn't change anything. – herpderp May 31 '11 at 17:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .