Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a MacBook Pro mid 2009 and a samsung SyncMaster B2230 monitor. I have connected them through the standard display port adapter and a DVI to HDMI connector cable. Now the display resolution is at 1080p.

My problem is, the font and the display or the pixels, are not as they should look like. If you look at the example screenshot I've provided, you will notice a white-ish fade in the font. The AntiAliasing wich should be there is not there or something like that.

What is the cause of this problem?
What would you suggest?

share|improve this question
    
That definitely looks weird. Is it just the fonts or does it happen on other UI elements as well? Have you tried with another cable? Does the monitor have a setting that might cause this? –  slhck May 31 '11 at 13:11
    
Did you reboot? Does it do this on the external monitor and the built-in display? Did you try enabling (or disabling if it's enabled already) font smoothing in System Preferences -> Appearance? Just grasping at straws a bit. Also try a Repair Permissions in Disk Utility followed by a reboot; I've seen that solve a lot of issues I never would have thought would be permissions-related. –  Justin Mrkva May 31 '11 at 13:41
    
Hello! This appear only on the external monitor. I tried another adapter cable but the DVI -> HDMI cable i only have one. But i doubt it's the cable. I've enabled font smothing and no, it did not change anything :( –  Herr K May 31 '11 at 13:57
    
Does nobody have a suggestion? :( –  Herr K Jun 5 '11 at 8:35
    
Have you tried changing your color profile? Have you tried a high-contrast, high-frequency image, (e.g. black/white stripes) if it shows the same symptoms? –  Daniel Beck Jun 5 '11 at 8:39
show 1 more comment

3 Answers

up vote 4 down vote accepted

This Mac OS X Hints tip describes how to fix the problem:

In Snow Leopard, you can only choose between Automatic and Standard CRT. Since few people use CRTs these days, most users now have only one option: Automatic. The problem with the Automatic option is that OS X incorrectly detects many third party LCD monitors as CRTs, and consequently, disables LCD font smoothing.

You can force OS X to use LCD font smoothing on all displays with this Terminal command:

defaults -currentHost write -globalDomain AppleFontSmoothing -int 2

The number 2 here corresponds to Medium - Best for Flat Panel. You may also use 1 for light smoothing, and 3 for strong smoothing, as per the original OS X font smoothing options.

You'll have to relaunch applications to see the effect in them.

share|improve this answer
add comment

I've had similar problem and I get things better (but not perfect IMHO) changing the configuration on the monitor OSD :

Menu Conf & reinit Mode PC/AV : PC

Note that I use a 2008 macbook pro connected by a DVI-HDMI cable to the monitor

share|improve this answer
add comment

I have the same monitor -- I had to turn on the Samsung "Magic Color" setting to fix that problem. No amount of calibration would solve it. Font smoothing 2 is also recommended as per the previous hint, but it was turning on Samsung's weird "magic color" crap that got rid of all the weird white antialiasing that was happening around the letters.

share|improve this answer
    
Thank you very much for your answer. This might as well serve for the solution of the problem :) –  Herr K Feb 9 '12 at 13:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.