Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First off all, I'm booting from a large MEMDISK using PXE (900MB) . Due to our environment, I cannot decrease the size, nor move files to a nfs/iSCSI/... environment. Everything needs to be in that MEMDISK.

Now, when I try to run the OS, I get out of vmalloc space. How do I increase it to a number which allows such a large image to be mapped? I tried the parameter "vmalloc=1280M", but with that parameter, I don't get past the Booting the kernel screen.

Memory should not be an issue, since the machine(s) have at least 2GB RAM. (900MB MEMDISK + 256MB for other kernel stuff + 768MB for user stuff). The machine(s) have a Pentium 4 Extreme Edition processor, with hyperthreading and SSE2, but no EM64T.

How can I boot the system, and get past that message? Decreasing the MEMDISK size is not possible too. It is at the smallest we can get with our userland + kernel + modules.

Thank you for you help!

Yvan Janssens

share|improve this question
up vote 1 down vote accepted

What do you mean by "memdisk"? If you are setting up /dev/ram and putting an ext3/4 fs on it, then don't do that; use a tmpfs instead.

share|improve this answer
    
I use the memdisk driver from Syslinux to load an entire HDD image into RAM through PXE – friedkiwi May 31 '11 at 19:09
    
@Yvan JANSSENS, how do you build the image? Is it an initrd, or initramfs? Is it built using mksquashfs? – psusi Jun 1 '11 at 0:59
    
actually, it's a full HDD image. Kernel is stored in the image, initrd too. I'm using this setup: syslinux.zytor.com/wiki/index.php/… . Basically, a hard disk is loaded into memory, the boot sector is executed, GRUB is loaded, GRUB loads kernel and initrd with phram patch, OS boots from Virtual HDD in RAM. – friedkiwi Jun 1 '11 at 7:44
    
You are using the 32bit kernel? Then there is no getting around that limit; you're going to have to redesign the system. – psusi Jun 1 '11 at 13:49
2  
Yes, a 32bit kernel. But I think it's solved now. I stripped all the binaries and development files from the image, and made it decompress to 750M. Then I used a vmalloc=850M parameter. Okay, not so elegant, but this way I can deploy my image to LiveCDs and PXE, without modifications. Thank you for your time ;-) – friedkiwi Jun 1 '11 at 21:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .