Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been messing around on a Solaris box, installing precompiled lib/programs from the repos by extracting them and placing them in my home dir.
It seems everything I've tried so far works, except for irssi.
I get the following error:

 $ ~/bin/irssi                                                                                                                                                                    
 ld.so.1: irssi: fatal: relocation error: file /export/home0/leem2/bin/irssi: symbol boot_DynaLoader: referenced symbol not found
 Killed

Any ideas on how to debug this?

EDIT: I have run:

 $ ldd /export/home0/leem2/bin/irssi

and it has no missing libs.

share|improve this question
up vote 1 down vote accepted

In general, if you're missing a symbol yet have all your libs, you probably have a version issue - the app depends on a newer version of the library (with the symbol) than what you have.

However, this seems to be strictly a perl-embed issue.

share|improve this answer
    
installing a newer version of perl and making sure the path variables point to the right one fixed it – madmaze Jun 12 '11 at 20:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .