Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an HP dv4 notebook, which has an ir receiver on the front. I want to configure it so that no matter what, IR signals will not trigger vista media center to start. It currently starts whether the computer is on or in sleep mode in response to MCE remote commands being directed at another computer in the room. how do I make the notebook ignore the ir commands?

Ive tried uninstalling the IR tranceiver device, whenever I reboot windows reinstalls the drivers for it and im back where i started.

share|improve this question

4 Answers 4

up vote 2 down vote accepted
+100

Low-tech solutions for high-tech problems. Don't laugh. Cut a strip of duct tape and paste it over the IR window. I had to resort to this on an old Compaq notebook that kept trying to transfer files whenever my Treo came near.

share|improve this answer
1  
I'm certainly not laughing, in fact I tried this before. The only problem is that it's my wife's laptop, and the WAF on the tape is quite low. Maybe I can sell her on some black paint. If so, you win :) –  Jeff Shattock Oct 4 '09 at 21:03
    
Black nail polish. 4 coats, and its IR-opaque. Problem solved, thanks much. –  Jeff Shattock Oct 5 '09 at 15:19
    
"The WAF on the tape is quite low." - LOL, classic! –  skypecakes Jan 19 '10 at 8:20

no option in the BIOS to disable the IR receiver?

share|improve this answer
    
no, this bios is pretty slim. no options to enable or disable devices –  Jeff Shattock Aug 28 '09 at 21:56
    
thought so ... that's Hewlett-Packard for ya :( –  Molly7244 Aug 28 '09 at 22:06
1  
and you say disabling is not an option in the device manager? have you tried DevCon? robvanderwoude.com/devcon.php –  Molly7244 Aug 28 '09 at 22:10
    
devcon gives me a "disable failed" message when i try to disable the device. the Disable button is greyed out in device manager. –  Jeff Shattock Aug 28 '09 at 22:50

In Device Manager, highlight the IR device and right click. Select properties. Navigate to the Power Management tab (might be labeled differently in XP) and uncheck the box that says "Allow this device to wake the computer" and click apply.

share|improve this answer
    
No can do. The only tabs available on the property page for the device are General, Driver, and Details, all of which are inquiry-only. No Power Management tab, nothing I can update about a power management setting. I'm beginning to think that HP really doesnt want this thing disabled for some reason. –  Jeff Shattock Sep 30 '09 at 22:19

Have you tried steps like these (from a message board post):

1) Disable automatic driver downloads: - Start menu -> Right click Computer -> Properties -> Advanced System Settings (top left) -> Hardware -> Windows Update Drivers Settings -> Select "Never check for drivers when I connect a device." -> OK -> Apply -> OK

2) Turn off SSDP Discovery: - Start menu -> Type in "services.msc" without quotes and press Enter -> Scroll to "SSDP Discovery" -> Right click and select Properties -> Change Startup Type to "Disabled" -> Apply -> OK

3) Uninstall ENE CIR Receiver: - Start menu -> Right click Computer -> Manage -> Device Manager -> Click the + beside Human Interface Devices -> Right click "ENE CIR Receiver" and select Uninstall -> MAKE SURE TO CHECK THE UNINSTALL SOFTWARE BOX ON THE PROMPT (this will take the Microsoft eHome Infrared Trasceiver with it) -> OK -> Let the uninstall take place -> Reboot the computer

4) Preventing installation of IR device drivers: - Upon reboot you will receive a prompt asking you if you want to install the device drivers -> SELECT "NEVER FOR THIS DEVICE"

5) Turn ON SSDP Discovery: - Follow directions from earlier and select "Manual" from the drop down menu (Startup Type) -> Apply -> OK


Have you tried just disabling the IR transceiver?

share|improve this answer
    
there is no option in the device manager to disable it, only uninstall it. ill dig around further, but i havent been able to find anything to disable it with. –  Jeff Shattock Aug 25 '09 at 0:26
    
Have you tried the steps I just added to my answer above? –  hanleyp Aug 25 '09 at 0:40
    
(May not be the exact steps and IR device may be different.) –  hanleyp Aug 25 '09 at 0:41
    
I tried this, it made windows not boot after I disabled the services. –  Jeff Shattock Sep 30 '09 at 0:51
    
Did you only disable the SSDP Discovery service? –  hanleyp Sep 30 '09 at 1:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.