Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using gvim in windowed mode and use Windows 7's feature to dock it on one side.

Every time I open or close a vertical window within gvim (eg: ^w^v), Windows 7 decides to undock the program.

The only difference I can see in gvim is that, when there's a vertical division, there are scrollbars on BOTH sides of the window. Previously, it only had one on the right. I'm assuming that the adition/deletion of the right scrollbar is causing this behaviour but I do not know how to correct it.

Any ideas? Is the scrollbar really the problem?

Further info:
Windows 7 x64
gvim x64

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I'm not too much into the internals, but gvim will probably change its window state to display and hide the scrollbars (or even recreate its window), which may induce Windows to undock (or not re-dock).

Try :set go-=r go-=R go-=l go-=L to check. If that changes the behavior, try to find the setting you're most comfortable with. You could either always or never display the scrollbars, depending on your tastes. (Since Vim is very keyboard-oriented, a lot of Vim users, myself included, just do without scrollbars.)

See :help 'guioptions' for more about those settings.

share|improve this answer
    
The change will screw up things so g+=L or g+=R are the ones to avoid. You can just choose if you want g+=r or g+=l, both or none without modification upon window splits. Personally, I'll stick with no scrollbars. If I had to touch the mouse, then the mousewheel would suffice. Thank you very much, specially for adding the help 'guioptions' line so I could learn further. –  Isaac Remuant May 31 '11 at 23:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.