Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I ssh to my linux system from Mac. It started using remote system color. Is there a way I can force it to use original color ?

share|improve this question
    
Can you please update the spelling of "Mac"? :-) –  Chris Page Aug 29 '11 at 11:15
    
@Chris Page , I hope now it is correct. –  Vivek Goel Aug 29 '11 at 12:24
    
Yes, it is. Thanks! –  Chris Page Aug 29 '11 at 12:41
    
Can't you just change which terminal that session uses? I think it defaults to 'xterm-color', or 'xterm-color256'? I wanted to disable colors, so I believe I just set that session to use 'xterm'. But, maybe this is not what you're referring to... –  Chris Serra Aug 29 '11 at 12:54
    
but those color don't match with my mac terminal theme –  Vivek Goel Sep 18 '11 at 19:21

1 Answer 1

up vote 3 down vote accepted

Not easily. It no longer knows what the original system's colors are after you ssh, so you'd have to configure the local ssh to send that information as environment variables, and the remote ssh to read them. See SendEnv in the ssh_config(5) man page, AcceptEnv in the sshd_config(5) man page, and the SSHRC section of the sshd(8) man page.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.