Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just finished setting up a default Linux EC2 instance and would like to install PHPMyAdmin. I already have Apache and MySQL installed but cannot seem to install PHPMyAdmin. I tried using

sudo apt-get phpmyadmin but the command apt-get is not recognized.

I also tried sudo yum install phpmyadmin but that I get the message No package phpmyadmin available.

Any suggestions on what I am doing wrong?

share|improve this question
up vote 37 down vote accepted

I found an easy solution here.

Do the following:

  1. Navigate to the apache folder

    cd /var/www/html
  2. Ensure ownership of the folder (assuming signed in with ec2-user)

    sudo chown ec2-user .
  3. Download phpMyAdmin

  4. Unzip

    tar -jxf phpMyAdmin- -C /var/www/html
  5. Rename the folder

    mv phpMyAdmin- phpmyadmin
  6. Remove the zip file

    rm -rf phpMyAdmin-

That's the basics. You can find more info in the link provided above.

share|improve this answer
You can find the latest version of phpMyAdmin here: – jchavannes Sep 8 '13 at 0:33
the only additional step I had to take was updating the server host endpoint for my RDS database in /etc/phpMyAdmin/ -- changing $cfg['Servers'][$i]['host'] = 'localhost' to $cfg['Servers'][$i]['host'] = '' – Damion Hankejh Oct 9 '13 at 17:43
After installation, the phpmyadmin page is empty in my – Zhou Hao Mar 20 '14 at 8:18
After following all these steps, i'm not seeing phpMyAdmin. where do i find it? – Jeremy - DeerAngel-org Jun 9 at 16:21

I know the question has more than one year, but was the first thing that popped up on google with "phpmyadmin ec2". Here is a better way to do things.

Knowing that you have yum, the best way to act is to install it by yum.

The easy way is to activate it just to install the packages you want, like phpMyAdmin or MongoDB. Eg.

sudo yum --enablerepo=epel install phpmyadmin

and it should work.

EDIT (comment by @eric-brotto):

It also should be noted that this comes with the advantage of uninstalling via

(sudo) yum erase phpmyadmin

Eric Brotto Jun 8 at 16:22

Note, that this would install phpmyadmin in /usr/share/phpmyadmin. To make it available in your web root, you would have to symlink it thus:

sudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadmin

There are two ways to use EPEL, one is above, the other is to activate it permanently, editing the file /etc/yum.repos.d/epel.repo and where it says enabled=0 we change it to enabled=1, now you can sudo yum install phpmyadmin.

Here you can see a package list for the EPEL repo, too.

share|improve this answer
I don't think it gets any easier than this. The tl;dr? Just copy and pasted yum --enablerepo=epel install phpmyadmin – Tuanderful Oct 12 '12 at 7:43
There are many answers on the web stating how to use yum to install phpmyadmin. None of them worked for me. This one does. A million up votes be showered unto thy! – Eric Brotto Jun 8 '13 at 16:18
It also should be noted that this comes with the advantage of uninstalling via yum erase phpmyadmin. – Eric Brotto Jun 8 '13 at 16:22
Rats. It's all installed. I've created the symbolic link. I've restarted the server but all I get is: You don't have permission to access /phpmyadmin on this server. – Django Reinhardt Feb 4 '15 at 15:01
For me, it's /usr/share/phpMyAdmin instead of /usr/share/phpmyadmin. That's phpMyAdmin with capital M and A. – Pang Mar 20 '15 at 3:03

First add the repository, then install:

sudo rpm -Uvh rpmforge-release-0.3.6-1.el5.rf.i386.rpm 
sudo yum install phpmyadmin 

This works fine on a standart 32bits amazon instance

share|improve this answer
Also working well on 64bit amazon linux. This is may be better for some users then the "accepted" answer as it resolves the dependencies faster then doing a manual install. – Nir Levy Feb 8 '12 at 15:34
note that you'll need to supplement this install with "ln -s /usr/share/phpmyadmin/ /var/www/html/phpmyadmin" – Nir Levy Feb 8 '12 at 15:36

Note that if, after using any of the above methods to install phpMyAdmin, the phpMyAdmin page is empty in, then you probably need to edit httpd.conf to allow overrides in the web directory, e.g.:

sudo nano /etc/httpd/conf/httpd.conf
  1. Find <Directory "/var/www/html">
  2. Replace AllowOverride none with AllowOverride all
  3. Save changes and exit
  4. Restart Apache server

    sudo service httpd restart
share|improve this answer

I don't have permissions to comment, so as a separate answer.

1) Check what LINUX you have

rpm -q centos-release
lsb_release -a
uname -m

2) Check the correct rpm distribution release for you

3) Add that distribution

sudo rpm -Uvh rpmforge-release-0.3.6-1.el5.rf.i386.rpm 

4) Install the application

sudo yum install phpmyadmin 
ln -s /usr/share/phpmyadmin/ /var/www/html/phpmyadmin
vim /usr/share/phpmyadmin/

5) Create permissions to MySQL if necessary (replace pmapass with your own password!)

GRANT USAGE ON mysql.* TO 'pma'@'localhost' IDENTIFIED BY 'pmapass';
    Host, User, Select_priv, Insert_priv, Update_priv, Delete_priv,
    Create_priv, Drop_priv, Reload_priv, Shutdown_priv, Process_priv,
    File_priv, Grant_priv, References_priv, Index_priv, Alter_priv,
    Show_db_priv, Super_priv, Create_tmp_table_priv, Lock_tables_priv,
    Execute_priv, Repl_slave_priv, Repl_client_priv
) ON mysql.user TO 'pma'@'localhost';
GRANT SELECT ON mysql.db TO 'pma'@'localhost';
GRANT SELECT ON TO 'pma'@'localhost';
GRANT SELECT (Host, Db, User, Table_name, Table_priv, Column_priv)
    ON mysql.tables_priv TO 'pma'@'localhost';
share|improve this answer

The package is called phpMyAdmin. You may need to enable EPEL first.

share|improve this answer
Can you provide more clarification? How do I go about enabling EPEL? – David May 31 '11 at 21:04
Did you try reading "How can I use these extra packages?"? – Ignacio Vazquez-Abrams May 31 '11 at 21:11
That looks way too difficult just to install phpMyAdmin. See my answer for a better solution. – David Jun 2 '11 at 15:07

As of 13th December 2012, this works fine on an EC2 server:

sudo apt-get install phpmyadmin

No other steps necessary, assuming you have PHP, MySQL and Apache all set up.

share|improve this answer
How can I access it through web browser once installed ? – Alwin Augustin Jun 28 '14 at 7:21
apt-get is not available. – Django Reinhardt Feb 4 '15 at 14:43
sudo apt-get install phpmyadmin

once you have installed it, you must make a symbolic link (like a redirect) using

sudo ln -s /usr/share/phpmyadmin /var/www

to open (change your IP) http://XXX.XXX.XXX.XXX/phpmyadmin

you MIGHT see an error missing mcrypt. i couldnt solve, but it didnt get in the way.

for logging in user is "root" and the password is the one that you created during the phpmyadmin install

adapted from this tutorial

share|improve this answer
The question specifically says that apt-get is not available. – Nick F Jun 6 '13 at 15:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .