Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As backstory: I installed fileserve manager to help me download files from fileserve, and was rather annoyed to put it lightly that it became the default download manager for all downloads in Chrome. I was more annoyed that the option to remove it (via fileserve options) didn't work. So I tried to remove it by disabling the plugin that fileserve had installed. No dice.

I ended up removing the program entirely, and hoping, and it worked, but it did bother me that there did not seem to be a way in chrome to reset the download manager to the default. Is there a way to do that / see what it is currently set as?

Windows 7, using Chrome 13 Dev (but bug was also under 11 (stable))

share|improve this question
    
So the error propagated throughout updating Chrome? Does it work when you create a new profile? (Remember to back up the old one) –  slhck May 31 '11 at 21:43
    
Did not do that. The question is more about seeing it and removing it than finding the least invasive way to excise all of one's settings. –  soandos May 31 '11 at 21:45
    
I figured, yeah. Googling for "Fileserve Manager Chrome" gives me more entries for removing it (mostly cr*pware and content farms). I don't really want to try it out to see what changes, but I'm relatively sure the Preferences file in your profile root contains traces of the rogue extension. So just comparing it before and after installation might give you hints. –  slhck May 31 '11 at 21:59
    
But I disabled it (least I thought I did, and I recognize the other items on the extension list). I just wish there was a way to see the setting for the download manager. –  soandos May 31 '11 at 22:00
    
I'm not sure I know what you mean when you say "download manager", but I can tell you that if you want to change the location of the saved file, or prompt you for a location each time, you can do that from here: chrome://settings/advanced –  wizlog Jul 31 '11 at 17:01
show 1 more comment

5 Answers

up vote 1 down vote accepted

Just use the Download Assistant extention. Once installed, go to the options (Wrench>Tools> extensions> and click options under the "Download Assistant") then just select the default download manager you want.

share|improve this answer
    
the dead is link –  Simon Feb 23 '13 at 8:03
    
@Simon Try again, I replaced it with a different one. –  wizlog Feb 24 '13 at 15:11
    
HORRIBLE answer. You give work arounds vs the actual solution. This will not serve you well in the IT world. –  OG Chuck Low May 8 '13 at 17:47
    
The user CLEARLY wanted to go NO plugin NO addin. He wanted Chrome reset to default behavior. What was so hard to grasp about that? –  OG Chuck Low May 8 '13 at 17:49
add comment

I had the same problem, but with Free Download Manager rather than FileServe.

The fix for me was to visit chrome://plugins and disable Free Download Manager Click Catcher Plug-In for Netscape, Opera, Mozilla.

Presumably FileServe would be under there too, but if not you might also want to look at chrome://extensions to see if it's installed as an extension (rather than a plugin).

share|improve this answer
add comment

Elsewhere on Google this doesn't have an answer either but maybe:
http://www.windowsvalley.com/reset-google-chrome-to-default-configuration-without-re-installation/

NOTE: You may lose all program settings, bookmarks etc after deleting User Data.

We can restore the first run by simply deleting this file; the file can be found in the root of the installation directory or default locations:

For Windows XP:

C:\Documents and Settings\UserName\Local Settings\Application Data\Google\Chrome\Application

For Windows Vista or later:

C:\Users\UserName\AppData\Local\Google\Chrome\Application

In addition, Google Chrome creates a folder User Data to store personalize settings including preferences, history, download list etc. To reset them, just delete all the files and folders from User Data. The locations are:

For Windows XP:

C:\Documents and Settings\UserName\Local Settings\Application Data\Google\Chrome\User Data

For Windows Vista or later:

C:\Users\UserName\AppData\Local\Google\Chrome\Application\User Data


Note: in Vista/Windows 7:

  • Documents and Settings -> C:\Users
  • My Documents -> C:\Users\youraccount\Documents
  • My Music -> C:\Users\youraccount\Music
  • Application Data -> C:\Users\youraccount\AppData

Applies to:

Google Chrome (all version including betas)

share|improve this answer
add comment

I had the same problem with Free Download Manager. I uninstalled the program but it left the trace in Google Chrome. The message would tell me to remove the plugin called npfdm.dll, but I couldn't find it. It wouldn't work to tell Chrome to ask where to put any downloads, it still tried to go to FDM (Free Download Manager).

Here is the solution I found:

  1. Go to your C: DRIVE or whatever drive your Google Chrome is operating from.
  2. Click on C:\Program Files, then Google then Chrome then Application then plugins and that is where I found the file npfdm.dll.
  3. I right-clicked and deleted it.
  4. Re-started Google Chrome and I am back to the default way of saving downloads.

Hope this helps someone. I am running Windows 7.

share|improve this answer
add comment

Its likely that the file-download application installed itself as the "handler" for the many types of files you normally download. So even though you removed the plugin, the handlers would still try to open the manager for each registered file-type.

Try going into Chrome Options > Under The Hood > Content Settings > Handlers .. and remove any handlers installed that point to Fileserve Manager.

share|improve this answer
    
I don't see any such area in the under the hood section... –  soandos Aug 7 '11 at 1:13
    
Woops .. the handlers are under Content Settings. Will correct the comment above. –  Sanjay Sheth Aug 7 '11 at 9:43
    
Nope, nothing there, sorry. –  soandos Aug 7 '11 at 11:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.