Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Ubuntu 11.04 with gnome-shell and I have a conflict in apt-get that don't let me upgrade / install new packages (my system is in Spanish, because of that some output is in this language)

when I run apt-get upgrade:

Tal vez quiera ejecutar «apt-get -f install» para corregirlo. Los siguientes paquetes tienen dependencias incumplidas:  gnome-session : Depende: gnome-session-common (=
3.0.1-0ubuntu1~build2) pero 3.0.2-0ubuntu3~natty1 está instalado E: Dependencias incumplidas. Pruebe de nuevo usando -f.

gnome-sessions depend on gnome-session-common (= 3.0.1-0ubuntu1~build2) but 3.0.2-0ubuntu3~natty1 is installed

If I run apt-get -f install:

dpkg: error al procesar /var/cache/apt/archives/gnome-session_3.0.2-0ubuntu3~natty1_all.deb (--unpack):
 intentando sobreescribir `/usr/share/xsessions/gnome-shell.desktop', que está también en el paquete gnome-shell 3.0.1-0ubuntu1~build1
Se encontraron errores al procesar:
 /var/cache/apt/archives/gnome-session_3.0.2-0ubuntu3~natty1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have a similar error.

apt-get clean apt-get autoclean

with or without "-f" have similar outputs

etc/apt/sources.list:

deb http://es.archive.ubuntu.com/ubuntu/ natty main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ natty main restricted

deb http://es.archive.ubuntu.com/ubuntu/ natty-updates main restricted
deb-src http://es.archive.ubuntu.com/ubuntu/ natty-updates main restricted

deb http://es.archive.ubuntu.com/ubuntu/ natty universe
deb-src http://es.archive.ubuntu.com/ubuntu/ natty universe
deb http://es.archive.ubuntu.com/ubuntu/ natty-updates universe
deb-src http://es.archive.ubuntu.com/ubuntu/ natty-updates universe

deb http://es.archive.ubuntu.com/ubuntu/ natty multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ natty multiverse
deb http://es.archive.ubuntu.com/ubuntu/ natty-updates multiverse
deb-src http://es.archive.ubuntu.com/ubuntu/ natty-updates multiverse

deb http://security.ubuntu.com/ubuntu natty-security main restricted
deb-src http://security.ubuntu.com/ubuntu natty-security main restricted
deb http://security.ubuntu.com/ubuntu natty-security universe
deb-src http://security.ubuntu.com/ubuntu natty-security universe
deb http://security.ubuntu.com/ubuntu natty-security multiverse
deb-src http://security.ubuntu.com/ubuntu natty-security multiverse

deb http://extras.ubuntu.com/ubuntu natty main
deb-src http://extras.ubuntu.com/ubuntu natty main


deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu natty main
deb-src http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu natty main

can anybody help me?

share|improve this question
    
What's in your /etc/apt/sources.list? There must be something other than the regular Ubuntu archives, since Ubuntu package search doesn't show mention gnome-sessions at all (just gnome-session), and this post references a Gnome PPA. –  Mike Renfro Jun 2 '11 at 12:35

2 Answers 2

I think the mirror you currently use is broken, or not totally synced.
Simply switch mirrors with Synaptic, or use a text editor.

With Synaptic, you can do the switch from the options.
If you want to use a text editor, do the following:
1) Open up a terminal
2) Type: gksu gedit /etc/apt/sources.list
3) Edit -> Replace All.
4) Replace all the country strings, to an anouther country.

Like in my case, I have "hu.archive." by default, which is the worse mirror I've ever seen. So I go there after every install, and change the "hu" part to "de" as in Germany. So it looks like this: de.archive. (All the lines where there is a country PREfix.)

After this, do an apt-get update and then, try the upgrade (again).

share|improve this answer
    
thanks but it isn't the problem. :( –  Mordi Jun 1 '11 at 23:41

Remove the stuff you added to source.list. Execute this command first:

$ sudo add-apt-repository ppa:gnome3-team/gnome3

After you have entered your password and it is added, do this:

$ gksu apt-get update

Afterwords, upgrade all packages with

$ sudo apt-get dist-upgrade

You will then require gnome-shell:

$ sudo apt-get install gnome-shell

Afterwards, just reboot and at login you should be able to select Gnome Shell Desktop from the menu

share|improve this answer
    
This post helped me resolve a small apt-get update issue I was having earlier. Thanks! –  Isxek Oct 25 '11 at 18:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.