Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How can I setup Remote Desktop Connection (RDP) when I've exhausted all my known searchable resources?

I am attempting to set up Remote Desktop Connection on my Windows 7 Ultimate version and have followed and/or read every page on the subject through Google's third page. I am at a loss on how to proceed on successfully connecting to my host PC from a remote location using RDP.

I am now successfully able to connect to my host computer from within an intranet connection using local routing numbers 192.168.1.1XX. However, when I attempt to connect it using my WAN IP address, I am unable to connect.

  1. I have followed the instructions on PortForward.com for my router (DIR-615 upgraded to latest firmware available on DLink.com) http://portforward.com/english/routers/port_forwarding/Dlink/DIR-615/Remote_Desktop.htm

  2. I have checked my port "open" status on http://canyouseeme.org/ and receive the following message when attempting to connect: Success: I can see your service on 24.205.5.29 on port (3389) Your ISP is not blocking port 3389.

After all of this, I am unable to connect to my RDP using my WAN IP even though I can connecting using my intranet IP.

I am sitting behind a Motorola Surboard Cable Modem fed into a DLink DIR-615 router. According to canyouseeme.org, my port forward is active. How can I debug this issue? Any help would be greatly appreciated.

share|improve this question

migrated from stackoverflow.com Jun 2 '11 at 3:48

This question came from our site for professional and enthusiast programmers.

    
Try out Teamviewer I think you'd prefer it. –  Griffin Feb 17 '13 at 18:39
    
the main problem is probably that your router cannot hairpin traffic IE cannot go out and come back in on the same interfaces. This is a common problem. If the external resources says your port forward is open and answering it is probably correct, Try to connect from someplace that isn't behind the modem doing the port forward and you should be all set. –  Doon Jul 28 '13 at 16:56

1 Answer 1

Assuming that you have port forwarding set up correctly, you did not mention the doing the following two things:

  1. Turning on RDP here: Start>Right Click on computer>Remote settings and enable it. This is easy to forget to do.
  2. Make sure the firewall is not blocking it for public or other connections: Start>Administrative Tools>Windows Firewall with Advanced Security>Inbound Rules>Enable Remote desktop for both Public and Domain,Private. You can test without the public one, but try both first to make sure it works.

Lastly, make sure you have set your internal IP address as a static address.

If this works for you, please come back and mark the question as answered.

share|improve this answer
    
I do appreciate the attempt! I checked that the remote desktop is enabled. I also looked at the Windows Firewall and Remote Desktop (TCP-in) for both Public and Domain,Private settings are enabled. Unfortunately, I'm still uanble to connect. I'm thinking it must be either my Motorola Surfboard cable modem or my DLink that is causing the issue :( –  Magnum Jun 2 '11 at 4:06
    
Try disabling the firewall and checking again. My ISP doesn't allow a loopback so I can't use that ISP to connect to the computer on the same ISP IP address. Try from a different location. –  wbeard52 Nov 25 '12 at 1:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.