Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've configured Mail.app, to use a IMAP server (dovecot).

I'm connecting to this IMAP server through several devices. However whenever I read a mail from another comps than my Mac, unless I click Synchronize "account", the mails I've read on other devices, and who have been found by Mail.app, before I read them, stay in the unread state.

Is there a way to get a real synchronization of the mails status (it's supposed to be a benefit of IMAP) ?

P.S: when going into a folder, then the unread count is updated. But I have to manually go to that folder to have the correct unread count.

share|improve this question
1  
I'm using Mail.app with hMailServer, and hMailServer preserves my read/unread counts perfectly. I also sync my Gmail with my desktop and laptop, and I've never seen this issue. Perhaps it's an issue with Dovecot? Can you also post what settings you have in Preferences -> Accounts -> Advanced for account name? –  EvilChookie Aug 25 '09 at 5:29
    
I also use IMAP on my Mac and have never had an issue with this when reading off my iPhone or Outlook on Windows. –  Diago Aug 25 '09 at 15:47
    
The only solution I have to this - my IMAP server is the basic WU-IMAP btw - is to not leave Mail.app running on the desktop machine. –  jrg Aug 25 '09 at 15:52
    
@EvilChookie, there are the settings you are asking for : media.slubman.info/drop/Picture%20208.png –  slubman Aug 25 '09 at 15:57
    
@Nambuls - Thanks. I was hoping to see something glaringly obvious (since the basic settings are very hard to foul up) but the only major difference is that mine downloads a copy of the message, including attachemnts (yours doesn't include attachments). Does changing that setting help? –  EvilChookie Aug 25 '09 at 16:12

1 Answer 1

I have seen Apple Mail take 30 seconds or a minute to refresh the read/unread when your in the process of fetching mail... But I've never had to manually Synchronize the account.

What happens if you hit "Get Mail" instead of Synchronize? Is it possible that you have it set to Fetch mail manually?

share|improve this answer
    
When hitting the "Get mail" it just go through my folders, but the unread count never change except for messages in the Inbox –  slubman Aug 25 '09 at 15:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.