Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to stream Netflix on an Acer Revo 3700 running Windows 7 Home Premium, but it hangs on the loading screen at 98% (after it has formatted the player to the right aspect ratio and added the controls, but before the video starts) with no error messages or failures.

I have two other machines on the same network, one running Windows 7 Home Premium and another running XP, which both stream faultlessly.

Things I have tried:

  • Both a wired and wireless connection to the router
  • Upgrading the video and audio drivers
  • IE, Chrome and Firefox
  • Boxee software
  • Connecting with a VGA cable instead of HDMI (in case it is a HDCP thing)
  • Uninstalling and reinstalling Silverlight.
  • Getting someway into loading a HD movie and turning "Allow HD" off

Does anyone know what Netflix is doing at the 98% load mark? Are there any log files? Anything else worth trying?

Full disclosure:

I'm using Netflix from the UK through a US based VPN. I've tried multiple VPNs and the problem is exactly the same, also the other machines on the same network through the same VPN work fine so I don't think this is the issue, but it might be a factor. The region check happens at around 7% and I get past that.

share|improve this question
I have the same issue when I attempt to load from my US NetFlix and not my Canadian one. I use a proxy server but the download to the US never completes. However, when I use my Canadian one, it works perfectly. Go figure. – user106989 Nov 27 '11 at 6:17
Are you still consuming bandwidth? – soandos Nov 27 '11 at 6:22

I tried everything and the only thing that worked for me after countless attempts following the suggestions of others I've found in my search for an answer is as follows: I opened Microsoft Silverlight from the Start Menu>All Programs>Microsoft Silverlight>Microsoft Silverlight and selected the application data tab. I then deselected to allow application storage and deleted Netflix from the list and tried to use Netflix. After receiving an error on Firefox pointing at Silverlight as the cause, I reselected to allow application storage and clicked OK. It works now. Good luck.

share|improve this answer

I had a similar problem here in the US when they were barring HD video cards. The frustration was the process was nearly complete when it failed. I contacted them and they explained (no error message). My guess is you are also failing a final validation check. The behavior was the same and very frustrating. FYI I can now use my HD video card. Time may heal your problem too...

share|improve this answer
I certainly agree that is probably a hardware issue, since it works for other machines on the same network, but a quick Google for "Revo 3700 Netflix" has a lot of people complaining they can't view HD, but no signs that it doesn't work at all. Any Revo owners out there who would care to share their driver details? – Martin Harris Jun 2 '11 at 15:17
Actually the issue I am discussing was man made as in copyright protection agreements. According to NetFlix they disabled service (at the very last step of starting movie) due to my HD video link (that had an analog hole). Nothing changed but they now allow my setup on that system. Perhaps you are in my previous situation. – zedman9991 Jun 2 '11 at 20:10

Netflix also verifies that your computer's clock time is consistent with the IP address it presents to the Netflix server. I get the same hang at 98% until I change my computer's clock from a European time zone to the New York time zone (where my VPN tunnel terminates).

By accident I learned something else interesting about Nexflix and VPN's. For some reason my (Windows L2TP) VPN once disconnected during the (Chrome) playing of a Netflix movie, but the movie continued to play anyway! So then I began disconnecting my VPN intentionally shortly after the preliminaries reached 100% and the movie began to play, and again, the movie continued to play.

This indicates that the test for North American IP's happens only during the preliminaries, and that the stream, once running, follows any changes in your IP address and port number. That's rather unconventional, but it makes sense if your device were a smartphone that might roam from one provider to another during the playing of a movie.

This is good news indeed. Disconnecting the VPN reduces the latency and increases the bandwidth between you and the Netflix server (reducing jerkiness and skips), reduces the monthly data budget you need from your VPN server, and reduces the crypto processing load both in your own device and in your VPN server.

share|improve this answer

I had the same problem: solution for me was to right-click the red loading screen for Silverlight options, then check Hardware Accelerated Playback under the Playback tab.

share|improve this answer

For me the problem was that Norton was checking through the key files, and had not finished that - once Norton had completed the Netflix installation continued as expected.

share|improve this answer

In case of accessing Netflix through a VPN, I think the issue could be the unreachability of during the authorization of the Silverlight player. In my case this was due to the MTU set on the PPTP connection I was using (1400), when lowered to 1370 it all started working. To change the MTU of a VPN connection under Windows, simply connect the VPN, then open a command prompt, type:

netsh interface ipv4 show subinterfaces

Take note of the name of the VPN interface then type:

netsh interface ipv4 set subinterface "interface name" mtu=1370 store=persistent

Then disconnect and reconnect the VPN.

I guess the bigger MTU messes up some router or firewall around the globe - I'm no expert whatsoever.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .