Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to use the character encoding UTF-8 (without BOM) on my files. I can change the encoding from the "Format" menu, but it is reset every time I create a new file or open a file.

How can I do so Notepad++ uses UTF-8 (without BOM) as default encoding?

share|improve this question
    
hey @Jonas, Do you mean use UTF-8 (without BOM) as default encoding for multiple sessions? I use notepad++ and cannot seem to replicate this behavior. Could it be a profile issue? – slotishtype Jun 2 '11 at 14:37
up vote 18 down vote accepted

Go to

Settings -> Preferences -> New Document/ Open Save Directory

and then in

New Document -> Encoding check UTF8 without BOM

share|improve this answer
    
Thanks! This worked perfectly for me for viewing Chinese Simplified characters. – Bad Programmer Mar 15 '13 at 20:00

Just bumping once again here at superuser

Step 1: Settings -> Preferences -> New Document ->[Encodng] UTF-8 without BOM (check Apply to opened ANSI files)

but any how it hadn't solved mine , i searched out and found that its a bug!

Notepad++ v6.4.5 bug fixes:

1.Fix a crash issue while there's missing tag in functionList.xml. 

2.Fix UTF-8 (w/o BOM) detection bug.

Step 2: That's all have an update to >= v6.4.5 and follow Step 1

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .