Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

(Full disclosure: I am a no linux expert, but not a complete novice.)

I have been following along with Linux from Scratch 6.8 and everything has been going well. I got past an issue with GRUB (Ubuntu 11.04 uses a different version of GRUB than LFS so caused some issues).

Now when I boot into the Linux kernel recommended in the LFS book, 2.6.37, I get the following kernel panic: "VFS: Cannot open root device "sdf6" or unknown-block(0,0)". I'm sure this means that I didn't load the right drivers when I configured the kernel. But I went back in and recompiled and chose every SATA driver listed and I still got that error. It does let me boot into the kernel that Ubuntu used (2.6.38) so I guess I'm ok. I just want to know how to get the 2.6.37 to compile right.

Is there a way for me to see what is going wrong, or to compare what is in one version versus the other? I don't know what I should be looking for or where to look.

share|improve this question
add comment

1 Answer

This might also be related to to missing file system support in your kernel. Make sure your kernel supports the file system you use on your root device (sdf6). Check with fdisk /dev/sdf which file system your sdf6 partition is using and make sure your kernel includes the appropriate drivers. Also make sure the required SATA and file system drivers are NOT compiled in as a module - else the kernel is unable to load the required driver from the root FS it just tries to mount.

I've also found this thread where a similar problem occurred due to initrd configuration. But you did not state anything about initrd. So you're probably not using one.

share|improve this answer
    
Thanks. I am assuming you meant fdisk and not fidisk? If you did mean fidisk, I don't have that program installed. So, the file system is ext3. I am relatively sure that I compiled in the drivers for that. It can read /boot right? and that's ext4. Also, I think I compiled in the SATA drivers for everything that was listed. Is it possible that the drivers I need weren't there? Could I add them in some other way? –  SuperBrian Jun 2 '11 at 14:49
    
Yes you're right. I meant fdisk of course. Having ext4 drivers does not mean that you have ext3 drivers too (however ext4 drivers can read ext3 drives as well). Maybe the type is specified wrongly in the partition table. Make sure type is set to "83, Linux" in fdisk and make sure ext3 + ext4 are enabled (CONFIG_EXT3_FS=y and CONFIG_EXT4_FS=y in your kernel config). –  SkyBeam Jun 2 '11 at 14:53
    
Thanks. It's set right in fdisk (83, linux) and both of those options are enabled in the config. –  SuperBrian Jun 2 '11 at 15:19
    
Did you read the thread I've linked? Do you use initrd? Maybe the issue could be there. What kind of hardware (SATA-controller) are you using? Are you sure the drivers are enabled too? –  SkyBeam Jun 2 '11 at 15:29
    
Going through that thread now. however, I noticed the following: for the grub entry that works and loads the newer kernel, it uses initrd. For the one that doesn't, there is no initrd command. Should I try adding one in? –  SuperBrian Jun 2 '11 at 15:52
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.