Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to list all of the files that are being copied by a cp command but the -v switch doesn't seem to exist on the servers here at work. I'm not sure exactly which OS this is. I think it might be SunOS. How could I find out if that is important?

Thanks

share|improve this question
1  
uname -a might tell you what the OS is. – Dennis Williamson Aug 25 '09 at 13:09
up vote 4 down vote accepted

You could use tar piped to tar instead, which may be more featureful, as you can harness the power of tar in addition to being a cross-platform verbosity solution.

tar -cvpf . - | (cd destination/directory && tar -xvpf -)
share|improve this answer
    
Thanks. That worked great. Helped me find why the files weren't appearing. I was running it from a shell script and the variables were set wrong. Hopefully I haven't left files all over the server from the times I got it wrong... – Android Aug 25 '09 at 7:01
    
Thanks! Worked for me too, but had to swap the order of the arguments for tar: tar -cvpf - . | (cd destination/directory && tar -xvpf -) – Eric B. Feb 3 '15 at 16:11

You could also try ditto (if it's present on your machine). ditto -V will print out each filename as it's copied.

share|improve this answer

One more option is rsync -v.

share|improve this answer

cat /etc/issue

to get the distro name


unison is lovely too if you can get it installed on the server

http://www.cis.upenn.edu/~bcpierce/unison/

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .