Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two internet connections in my home, one for myself and one for everyone else.

I have an Intel Pro 1000 PT dual gigabit port NIC which I bought so that I can have one port plugged into the modem for my internet and the other plugged into the other network so that other computers can access files on my computer.

The problem is that the data allowance on the internet connection for everyone else is very little so I don't want my computer to access the internet through the second connection. The reason for the file sharing is to stream movies over the network so I don't want to be enabling/disabling it all the time.

I have already tried setting a static IP on the second connection and blocking it through the router, but then I have all sorts of issues with applications in Windows (I'm using Windows 7 Business 64) trying to access the net through the other connection, not getting through the router and timing out instead of trying the other network connection. Pointing the DNS to the static address on the secondary connection wont suffice either because it's torrents I'm trying to stop from downloading through the other connection not browsing.

I've done a bunch of searching, what I'm trying to find out is if there is a way to disable internet but allow LAN traffic on a network connection through windows, drivers, or 3rd party software.

Thanks in adavnce

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Your setup is not entirely clear. I would have been better if you specified the ipconfig for each adapter.

That said, if you want to disable the Internet for a specific adapter, give it a static IP address, and don't specify a default gateway...leave it blank.

share|improve this answer
    
hur hur, removing gateway has done it :), Ir networking noob, didn't realise it would still be able to communicate w/ other computers w/o gateway. Thanks. –  zyfa Jun 3 '11 at 6:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.