Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Ubuntu desktop (11.04) at home which I'm using as my music box. It has both ssh and tangerine installed. I opened necessary ports on the machine, first. Then, I added two firewall rules to the router (one for ssh, one for tangerine) through which I am connected to the internet. It looks like the ssh setup is working properly since I can connect to the machine via ssh from a computer in my local network, and from another computer outside my home network. Similarly, I can connect to the daap server using machines in my home network; however when I try to connect from outside my network, I get an error which says...

Ok. I have just tried to connect to the daap share from a machine that is not in my network to get the same error again, and it worked this time. I tried it multiple times previously and it didn't work, but now it seems like it's working. Can someone please tell me the reason for such unpredictable behavior? (I tried this with rhythmbox.)

share|improve this question
    
.. so what did the error say? –  slhck Jun 3 '11 at 7:51
    
I don't remember. That's why I wanted to try again to see the error... to write the error description here. But it didn't happen. Basically, the error was shown because of that the connection failed. –  blahbaa Jun 3 '11 at 15:13
    
But how exactly did you connect? Did it work locally and fail externally at the same time? Otherwise maybe just the daap server wasn't ready yet. –  slhck Jun 3 '11 at 15:33
1  
I was already connected to the server from a computer in my local network and playing songs. Then I connected from a computer which was not in my home network, and it failed. I guess the error description was something like "message corrupt." So, either it worked locally and failed externally at the same time, like you said, or it was actually accessible externally, but the connection was not reliable for some reason which caused me to get the corrupt message error. –  blahbaa Jun 3 '11 at 15:39
    
Hm, that's strange. But let's be happy that it worked! Maybe your router had some hiccups. –  slhck Jun 3 '11 at 15:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.